Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-installer
Navigation:
Lists: gentoo-installer: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-installer@g.o
From: "Luis Flores soberon" <lmflores78@...>
Subject: Re: Using GLI
Date: Thu, 01 Sep 2005 23:52:53 +0000
Ok... Thank you for you answres...

>>Are you using the &quot;official&quot; experimental LiveCD?
No... I am using the normal CD.. I'll change..
>>Exactly what are you trying to do?
What I am trying to do is a live-cd that automatically installs everything  
without asking anything. To do tests (currently), i am working in a virtual 
machine.. I am using vmware.
So.. I boot up, then i connect to my machine (cause i haven't done a Live-CD 
yet, i'm working on that) and copy the src of the GLI (using scp) to the  
virtual machine so i can see hopw it actually works.
I was getting that error.. but both of you have answered me.. I have to use 
the experimental Live-Cd...
Now.. it comes a new question...
Using your experimental Live CD, how can i do so that the fisrt thing 
executed after the cd boots is a script (done by me), which will ask the 
user to confirm the installation process???. If the user says "yes" then i 
start executing installer-cli (e.g.)




<BLOCKQUOTE style='PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #A0C6E5 
2px solid; MARGIN-RIGHT: 0px'><font 
style='FONT-SIZE:11px;FONT-FAMILY:tahoma,sans-serif'><hr color=#A0C6E5 
size=1>
From:  <i>Andrew Gaffney &lt;agaffney@g.o&gt;</i><br>Reply-To:  
<i>gentoo-installer@g.o</i><br>To:  
<i>gentoo-installer@g.o</i><br>Subject:  <i>Re: 
[gentoo-installer] Using GLI</i><br>Date:  <i>Thu, 01 Sep 2005 12:17:08 
-0500</i><br>&gt;Are you using the &quot;official&quot; experimental LiveCD? 
If not, you're <br>&gt;SOL. The installer has requirements that aren't 
satisfied by the <br>&gt;normal release CDs. Also, I'm not sure what you're 
doing copying it <br>&gt;into /mnt/gentoo before running it. Exactly what 
are you trying to <br>&gt;do?<br>&gt;<br>&gt;Luis Flores soberon 
wrote:<br>&gt;&gt;I'm trying to use the Gentoo Installer and get it to work. 
To do my <br>&gt;&gt;tests I am using a virtual Machine inside my linux box 
and booting <br>&gt;&gt;up with the live-CD. Im copying the entire installer 
directory in <br>&gt;&gt;to the /mnt/gentoo directory, but it is not mount 
(it is in RAM). I <br>&gt;&gt;try to run the<br>&gt;&gt;./installer-clie 
with the arguments required (changing first the <br>&gt;&gt;INSTALL_DIR in 
the script)<br>&gt;&gt;and i keep getting this error 
:<br>&gt;&gt;<br>&gt;&gt;<br>&gt;&gt;Traceback (most recent call 
last):<br>&gt;&gt;  File 
&quot;/home/luis/installer/src/fe/cli/clife.py&quot;, line 13, in 
?<br>&gt;&gt;    import GLIClientController<br>&gt;&gt;  File 
&quot;/home/luis/installer/src/GLIClientController.py&quot;, line 17, 
<br>&gt;&gt;in ?<br>&gt;&gt;    import os, GLIClientConfiguration, 
GLIInstallProfile, <br>&gt;&gt;GLIUtility, GLILogger, sys, signal, Queue, 
GLIArchitectureTemplate, <br>&gt;&gt;GLINotification, traceback<br>&gt;&gt;  
File &quot;/home/luis/installer/src/GLIInstallProfile.py&quot;, line 28, in 
<br>&gt;&gt;?<br>&gt;&gt;    import GLIStorageDevice<br>&gt;&gt;  File 
&quot;/home/luis/installer/src/GLIStorageDevice.py&quot;, line 1, in 
?<br>&gt;&gt;    import commands, string, os, parted<br>&gt;&gt;ImportError: 
No module named parted<br>&gt;&gt;<br>&gt;&gt;What is 
happening???<br>&gt;<br>&gt;--<br>&gt;Andrew Gaffney                         
    <br>&gt;http://dev.gentoo.org/~agaffney/<br>&gt;Gentoo Linux Developer   
                                 Installer 
<br>&gt;Project<br>&gt;<br>&gt;--<br>&gt;gentoo-installer@g.o mailing 
list<br>&gt;<br></font></BLOCKQUOTE>


-- 
gentoo-installer@g.o mailing list


Replies:
Re: Using GLI
-- Chris Gianelloni
Re: Using GLI
-- Andrew Gaffney
References:
Re: Using GLI
-- Andrew Gaffney
Navigation:
Lists: gentoo-installer: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: Using GLI
Next by thread:
Re: Using GLI
Previous by date:
Re: Using GLI
Next by date:
Re: Using GLI


Updated Jun 17, 2009

Summary: Archive of the gentoo-installer mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.