Gentoo Archives: gentoo-java

From: "Petteri Räty" <betelgeuse@g.o>
To: gentoo-java@l.g.o
Subject: Re: [gentoo-java] Re: Re: Deprecating JDK 1.4
Date: Sat, 19 Jul 2008 17:06:39
Message-Id: 48821F13.1080302@gentoo.org
In Reply to: [gentoo-java] Re: Re: Deprecating JDK 1.4 by "Jörg Schaible"
Jörg Schaible kirjoitti:
> >> Also like I said - more and more things require 1.5, which means that all >> things depending on them also need to be >= 1.5. For example: new hessian >> requires >= 1.5, which means that mx4j needs also to be switched to 1.5, >> which means we have to switch anything depending on mx4j, and so on. > > So, and where can I define then my minimum supported JDK version > (setting -source and -target)? Can I define that my system should be JDK > 1.3 compatible - at least for all packages that support this (e.g. > commons-logging)? Will packages like mx4j slotted to have the last JDK 1.4 > compatible and the JDK 5 compatible version? ... No, I know. However, I > still have to provide JDK 1.3 (or at least 1.4) compatible software. And > this does not simply mean to compile code, it also means to run it! > > This will more or less lead to the situation, where I have to drop the > complete Gentoo Java packages (except the JDK's themselves) and install > everything else myself using the binaries. > > - Jörg >
There is no pressing need to start building 1.5 bytecode as long as an application compiles with 1.4 but if an application uses 1.5 features we will not be backporting the code to work with 1.4 which would be required for you to be able to run applications with 1.4. If you want to maintain such ebuilds we can give you access to an overlay where you can keep 1.4 compatible ebuilds around. The Java team doesn't have that much man power and it's better used towards other things than keeping 1.4 functional with our hundreds of packages. Regards, Petteri

Attachments

File name MIME type
signature.asc application/pgp-signature