Gentoo Archives: gentoo-java

From: Greg Tassone <greg@×××××××.net>
To: gentoo-java@l.g.o
Cc: "Petteri Räty" <betelgeuse@g.o>
Subject: Re: [gentoo-java] Question about Sun-Jdk 1.4.2.10
Date: Tue, 29 Nov 2005 21:01:36
Message-Id: 1133298068.8028.16.camel@localhost
In Reply to: Re: [gentoo-java] Question about Sun-Jdk 1.4.2.10 by "Petteri Räty"
On Tue, 2005-11-29 at 13:50 +0200, Petteri Räty wrote:
> Greg Tassone wrote: > > > > FYI: There is nothing "unstable" about JDK 1.5 (or Java 5).
...
> It has simply > > been package-masked here at Gentoo because there have been some > > lingering ebuilds that didn't compile cleanly with it. Hopefully it is > > going to be unmasked VERY soon. > > > > It also by default produces class files that are not compatible with > earlier versions etc.
...
> You can safely make 1.5 the user vm using java-config -s. But just be > sure you don't ever set it as the system vm.
Very true. Just to clear up any confusion for others on the list, this means that if you are trying to run a 1.5 JDK as the primary on your system at the same time you have a 1.4 JDK running, the 1.4 JDK will be unable to use most of the code compiled from the 1.5 JDK (by default). Since most packages on the Gentoo distro compile themselves from source (Java included), having a 1.5 JDK as your *system VM* means that your Java applications would be compiled so that ONLY Java 5 (and higher) runtimes could use the applications. This is a show-stopper for those still running a 1.4 JDK (at least for non-developers, who should know how to deal with this stuff anyway): Choices: * Run only 1.5 or higher on your system (with no intention of ever going back down). Note that as of a while ago certain packages in the Portage tree still required 1.4, so this approach may preclude installing those packages from Portage. --OR-- * Take Petteri's advice and leave 1.4 as the system VM, and set your "user" VM to 1.5 (or higher) if desired. HTH to clarify... Greg

Attachments

File name MIME type
signature.asc application/pgp-signature