Gentoo Archives: gentoo-java

From: Antony Riley <cyberiantiger@×××××.com>
To: gentoo-java@l.g.o
Subject: Re: [gentoo-java] Question about Sun-Jdk 1.4.2.10
Date: Wed, 30 Nov 2005 00:32:03
Message-Id: 90cabef30511291631u43df76eeidaeb060293bc23ff@mail.gmail.com
In Reply to: Re: [gentoo-java] Question about Sun-Jdk 1.4.2.10 by "Peter B. West"
There's a whole bunch of subtleties.

Just unmerge all your java packages, and try to re-emerge them with a
1.5system JVM.

New keywords.
Some packages build scripts use -source 1.1 -source 1.1 which the 1.5 javac
doesn't seem to support anymore. [goes as low as 1.2 now]

I'm sure there's more.

The "not backwards compatable to 1.5" is a bit of an error as many packages
seem to specify -source and -target in their build scripts.

I couldn't even get ant to build, which is fairly important for most java
packages.

I was thinking if you just patched ant to default the <javac> task to
-source 1.4 -target 1.5, you could probably get a mostly working system, but
the packages which set these explicitely would still be a problem, also it
may be a problem with 1.5 only packages that don't specify these [unless you
want to go around patching lots of build scripts]

I haven't looked at the experiement java stuff yet, might take a gander
sometime, so appologies if I'm saying stuff that's already been said.

On 11/29/05, Peter B. West <lists@××××××.au> wrote:
> > Greg Tassone wrote: > > On Tue, 2005-11-29 at 13:50 +0200, Petteri Räty wrote: > > > >>Greg Tassone wrote: > >> > >>>FYI: There is nothing "unstable" about JDK 1.5 (or Java 5). > > > > ... > > > >> It has simply > >> > >>>been package-masked here at Gentoo because there have been some > >>>lingering ebuilds that didn't compile cleanly with it. Hopefully it is > >>>going to be unmasked VERY soon. > >>> > >> > >>It also by default produces class files that are not compatible with > >>earlier versions etc. > > > > ... > > > >>You can safely make 1.5 the user vm using java-config -s. But just be > >>sure you don't ever set it as the system vm. > > > > > > Very true. Just to clear up any confusion for others on the list, this > > means that if you are trying to run a 1.5 JDK as the primary on your > > system at the same time you have a 1.4 JDK running, the 1.4 JDK will be > > unable to use most of the code compiled from the 1.5 JDK (by default). > > > > Since most packages on the Gentoo distro compile themselves from source > > (Java included), having a 1.5 JDK as your *system VM* means that your > > Java applications would be compiled so that ONLY Java 5 (and higher) > > runtimes could use the applications. This is a show-stopper for those > > still running a 1.4 JDK (at least for non-developers, who should know > > how to deal with this stuff anyway): > > > > Choices: > > > > * Run only 1.5 or higher on your system (with no intention of ever > > going back down). Note that as of a while ago certain packages > > in the Portage tree still required 1.4, so this approach may > > preclude installing those packages from Portage. > > --OR-- > > * Take Petteri's advice and leave 1.4 as the system VM, and set > > your "user" VM to 1.5 (or higher) if desired. > > > > HTH to clarify... > > > > Greg > > So who wants to run a 1.4 JDK? And what, exactly, prevents anything > from being compiled under 1.5? The only thing I can think of is the > user of the newly reserved word 'enum'. Big deal. How long has 1.5 > been around now? > > My perception is that there is only an ideological impediment to going > with 1.5. That is that it will be a long time before the > Stallman-approved JVMs support 1.5. So, the Java herd on Gentoo Stalls > the adoption of 1.5, just to "prove" that 1) you don't need it, and 2) > it's a very bad thing. Or at least it will be until the "free as in > slaves to ideology" crowd get their act together. Thanks for nothing. > > Peter > -- > Peter B. West <http://cv.pbw.id.au/> > Folio <http://defoe.sourceforge.net/folio/> > > >