Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-java
Navigation:
Lists: gentoo-java: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-java@g.o
From: Andrew Cowie <andrew@...>
Subject: Re: Problems with libgnome-java emerge
Date: Fri, 15 Jul 2005 11:31:33 +1000
On Thu, 2005-14-07 at 16:30 +0100, Peter B. West wrote:
> My java-config setting is sun-jdk-1.5.0.04, but I have tried this with ,

> and when I attempt to
> $ emerge --update libgnome-java, I get
> (cd .libs && rm -f libgnomejni.la && ln -s ../libgnomejni.la
>                                   libgnomejni.la)
> /opt/sun-jdk-1.4.2.08/bin/javac -classpath

I'm not sure off hand why it's actually using 1.4.2 and not your 1.5
install, but regardless, that's good, as the java-gnome hacker team
aren't developing with 1.5 at the moment.

As for why

>   /usr/share/libgtk-java-2.6/lib/gtk2.6-2.6.2.jar:./src/java:src/java -d
>   src/java src/java/org/gnu/gnome/About.java
> src/java/org/gnu/gnome/About.java:11: package org.gnu.gdk does not exist
> import org.gnu.gdk.Pixbuf;

didn't work, that actually has me a little puzzled. My first instinct
would be to ensure that the same compiler built both libgtk-java and
libgnome-java, but beyond that I'm not quite sure. Try setting your
compiler to 1.4, and then rebuilding libgtk-java-2.6.2

If you're building this to *use* it to develop something, I recommend
for further questions you come up on
java-gnome-developers@...

AfC
Sydney

P.S. We're getting close to a libgtk-java 2.6.3; I'll update the ebuild
just as soon as that does come to pass.

-- 
Andrew Frederick Cowie

Technology strategy, managing change, establishing procedures,
and executing successful upgrades to mission critical business
infrastructure.

http://www.operationaldynamics.com/

Sydney   New York   Toronto   London

-- 
gentoo-java@g.o mailing list


References:
Problems with libgnome-java emerge
-- Peter B. West
Navigation:
Lists: gentoo-java: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Problems with libgnome-java emerge
Next by thread:
SableVM SDK - update
Previous by date:
Problems with libgnome-java emerge
Next by date:
SableVM SDK - update


Updated Jun 17, 2009

Summary: Archive of the gentoo-java mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.