Gentoo Logo
Gentoo Spaceship

Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-java
Lists: gentoo-java: < Prev By Thread Next > < Prev By Date Next >
To: gentoo-java@g.o
From: Jörg Schaible <joerg.schaible@...>
Subject: Re: Re: Deprecating JDK 1.4
Date: Thu, 17 Jul 2008 21:50:05 +0200
Krzysiek Pawlik wrote:

> Jörg Schaible wrote:
>> Please note, that Sun is still supporting JDK 1.3 for *paying* customers.
>> It will take years till Sun is completely dropping 1.4:
> Yes, but the free Java world goes forward, plethora of projects use
> generics - and they require >= 1.5 (or any other feature of JDK 1.5).
>> Therefore I still have even 1.3 ebuilds on my local tree. And I had to
>> download and use the official ant binaries to run it with 1.3. Dropping
>> 1.4 means also that it is no longer possible to run Maven with its
>> minimum JDK requirement.
> Yes, but VM which is running maven is not the same as VM for which the
> code is generated (note -source and -target options of javac).

Be sure, I found them some years ago.

>> In Gentoo all is about choice, but this seem not to apply for Java
>> development. For me it gets unusable.
> You're missing the point: the official tree (gentoo-x86) will require
> >=1.5, *but*: if you install JDK 1.4 (or any other version) you can still
> use it for your own software (including maven, ant and so on).

Theoretically. At least in Gentoo. Using original binary distributions, it
is definitely possible.

> Also like I said - more and more things require 1.5, which means that all
> things depending on them also need to be >= 1.5. For example: new hessian
> requires >= 1.5, which means that mx4j needs also to be switched to 1.5,
> which means we have to switch anything depending on mx4j, and so on.

So, and where can I define then my minimum supported JDK version
(setting -source and -target)? Can I define that my system should be JDK
1.3 compatible - at least for all packages that support this (e.g.
commons-logging)? Will packages like mx4j slotted to have the last JDK 1.4
compatible and the JDK 5 compatible version? ... No, I know. However, I
still have to provide JDK 1.3 (or at least 1.4) compatible software. And
this does not simply mean to compile code, it also means to run it!

This will more or less lead to the situation, where I have to drop the
complete Gentoo Java packages (except the JDK's themselves) and install
everything else myself using the binaries.

- Jörg


gentoo-java@g.o mailing list

Re: Re: Re: Deprecating JDK 1.4
-- Petteri Räty
Deprecating JDK 1.4
-- Krzysiek Pawlik
Re: Deprecating JDK 1.4
-- Jörg Schaible
Re: Re: Deprecating JDK 1.4
-- Krzysiek Pawlik
Lists: gentoo-java: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: Re: Deprecating JDK 1.4
Next by thread:
Re: Re: Re: Deprecating JDK 1.4
Previous by date:
Re: GCJ with IcedTea classpath?
Next by date:
Detection of useless dependencies

Updated Jun 17, 2009

Summary: Archive of the gentoo-java mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.