Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-java
Navigation:
Lists: gentoo-java: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-java@g.o
From: David Bélanger <dbelan2@...>
Subject: SableVM SDK - update
Date: Sat, 16 Jul 2005 20:59:03 -0400
Hi all,

I started some time ago working on a meta-ebuild for a SableVM SDK but
I was then limited in time and never quite complete it.

Meanwhile the SableVM upstream started integrating various tools to
provide a full SDK.  The goal of SableVM upstream is to make SableVM,
its deps and 3rd party addition (gjdoc, fastjar, ...) easy to install
on several systems.

So I dropped work on the individual gjdoc, fastjar, ... ebuilds for now.
I will still keep them on gentooexperimental.org as some users might
want fastjar but not sablevm-sdk.  But I will concentrate on the
upstream-provided SDK instead of redoing the work.

Ebuild is here, take the version 1.12, the other one is the old
meta-package implementation:
http://gentooexperimental.org/svn/java/gentoo-java-experimental/dev-java/sablevm-sdk/

It would be good if some people could test it out.

Things to consider:

libffi - starting from 1.12, SableVM provides its own implementation of
         libffi.  If the internal is used, it will be compiled into
	 libsablevm (and not installed as a separate lib).
	 I have a libffi flag to say to use the system installed one.
	 Alternatively, I could remove that flag and always use the
	 internal or external one.  libffi is small and I think
	 libffi maintainer was at some point considering the removal
	 of the libffi stand-alone ebuild.- need to investigate this.

bootstrap issue:

SableVM includes gjdoc.
gjdoc depends on antlr.
antlr depends on a Java SDK.

I added a USE flag: nogjdoc that disable the installation of gjdoc,
removing the dependency on antlr.

So if the user do not have antlr installed and want to compile
antlr with SableVM SDK, he or she will have to build SableVM SDK
twice - once with USE=nogjdoc and once without.  Upgrading SableVM SDK
should not be an issue as antlr will have already been installed.
Any other solution?


David

---

David Bélanger
Web page:   http://www.cs.mcgill.ca/~dbelan2/
Public key: http://www.cs.mcgill.ca/~dbelan2/public_key.txt


-- 
gentoo-java@g.o mailing list


Navigation:
Lists: gentoo-java: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Problems with libgnome-java emerge
Next by thread:
Struts 1.1 Dependency for Tomcat 5.5.7?
Previous by date:
Re: Problems with libgnome-java emerge
Next by date:
Struts 1.1 Dependency for Tomcat 5.5.7?


Updated Jun 17, 2009

Summary: Archive of the gentoo-java mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.