Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-java
Navigation:
Lists: gentoo-java: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-java@g.o
From: Antony Riley <cyberiantiger@...>
Subject: Re: Question about Sun-Jdk 1.4.2.10
Date: Wed, 30 Nov 2005 00:31:32 +0000
There's a whole bunch of subtleties.<br>
<br>
Just unmerge all your java packages, and try to re-emerge them with a 1.5 system JVM.<br>
<br>
New keywords.<br>
Some packages build scripts use -source 1.1 -source 1.1 which the 1.5
javac doesn't seem to support anymore. [goes as low as 1.2 now]<br>
<br>
I'm sure there's more.<br>
<br>
The &quot;not backwards compatable to 1.5&quot; is a bit of an error as many
packages seem to specify -source and -target in their build scripts.<br>
&nbsp;<br>
I couldn't even get ant to build, which is fairly important for most java packages.<br><br>
I was thinking if you just patched ant to default the &lt;javac&gt;
task to -source 1.4 -target 1.5, you could probably get a mostly
working system, but the packages which set these explicitely would
still be a problem, also it may be a problem with 1.5 only packages
that don't specify these [unless you want to go around patching lots of
build scripts]<br>
<br>
I haven't looked at the experiement java stuff yet, might take a gander
sometime, so appologies if I'm saying stuff that's already been said.<br>
<br><div><span class="gmail_quote">On 11/29/05, <b class="gmail_sendername">Peter B. West</b> &lt;<a href="mailto:lists@...">lists@...</a>&gt; wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Greg Tassone wrote:<br>&gt; On Tue, 2005-11-29 at 13:50 +0200, Petteri R├Ąty wrote:<br>&gt;<br>&gt;&gt;Greg Tassone wrote:<br>&gt;&gt;<br>&gt;&gt;&gt;FYI:&nbsp;&nbsp;There is nothing &quot;unstable&quot; about JDK 1.5 (or Java 5).<br>
&gt;<br>&gt; ...<br>&gt;<br>&gt;&gt; It has simply<br>&gt;&gt;<br>&gt;&gt;&gt;been package-masked here at Gentoo because there have been some<br>&gt;&gt;&gt;lingering ebuilds that didn't compile cleanly with it.&nbsp;&nbsp;Hopefully it is
<br>&gt;&gt;&gt;going to be unmasked VERY soon.<br>&gt;&gt;&gt;<br>&gt;&gt;<br>&gt;&gt;It also by default produces class files that are not compatible with<br>&gt;&gt;earlier versions etc.<br>&gt;<br>&gt; ...<br>&gt;<br>&gt;&gt;You can safely make 
1.5 the user vm using java-config -s. But just be<br>&gt;&gt;sure you don't ever set it as the system vm.<br>&gt;<br>&gt;<br>&gt; Very true.&nbsp;&nbsp;Just to clear up any confusion for others on the list, this<br>&gt; means that if you are trying to run a 
1.5 JDK as the primary on your<br>&gt; system at the same time you have a 1.4 JDK running, the 1.4 JDK will be<br>&gt; unable to use most of the code compiled from the 1.5 JDK (by default).<br>&gt;<br>&gt; Since most packages on the Gentoo distro compile themselves from source
<br>&gt; (Java included), having a 1.5 JDK as your *system VM* means that your<br>&gt; Java applications would be compiled so that ONLY Java 5 (and higher)<br>&gt; runtimes could use the applications.&nbsp;&nbsp;This is a show-stopper for those
<br>&gt; still running a 1.4 JDK (at least for non-developers, who should know<br>&gt; how to deal with this stuff anyway):<br>&gt;<br>&gt; Choices:<br>&gt;<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; * Run only 1.5 or higher on your system (with no intention of ever
<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; going back down).&nbsp;&nbsp;Note that as of a while ago certain packages<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; in the Portage tree still required 1.4, so this approach may<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; preclude installing those packages from Portage.
<br>&gt;&nbsp;&nbsp;--OR--<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; * Take Petteri's advice and leave 1.4 as the system VM, and set<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; your &quot;user&quot; VM to 1.5 (or higher) if desired.<br>&gt;<br>&gt; HTH to clarify...<br>&gt;<br>&gt; Greg
<br><br>So who wants to run a 1.4 JDK?&nbsp;&nbsp;And what, exactly, prevents anything<br>from being compiled under 1.5?&nbsp;&nbsp;The only thing I can think of is the<br>user of the newly reserved word 'enum'.&nbsp;&nbsp;Big deal.&nbsp;&nbsp;How long has 1.5<br>
been around now?<br><br>My perception is that there is only an ideological impediment to going<br>with 1.5.&nbsp;&nbsp;That is that it will be a long time before the<br>Stallman-approved JVMs support 1.5.&nbsp;&nbsp;So, the Java herd on Gentoo Stalls
<br>the adoption of 1.5, just to &quot;prove&quot; that 1) you don't need it, and 2)<br>it's a very bad thing.&nbsp;&nbsp;Or at least it will be until the &quot;free as in<br>slaves to ideology&quot; crowd get their act together.&nbsp;&nbsp;Thanks for nothing.
<br><br>Peter<br>--<br>Peter B. West &lt;<a href="http://cv.pbw.id.au/">http://cv.pbw.id.au/</a>&gt;<br>Folio &lt;<a href="http://defoe.sourceforge.net/folio/">http://defoe.sourceforge.net/folio/</a>&gt;<br><br><br></blockquote>
</div><br>
References:
Re: Question about Sun-Jdk 1.4.2.10
-- Peter B. West
Navigation:
Lists: gentoo-java: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: Question about Sun-Jdk 1.4.2.10
Next by thread:
Re: Question about Sun-Jdk 1.4.2.10
Previous by date:
Re: Question about Sun-Jdk 1.4.2.10
Next by date:
Re: Question about Sun-Jdk 1.4.2.10


Updated Jun 17, 2009

Summary: Archive of the gentoo-java mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.