Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-java
Navigation:
Lists: gentoo-java: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: Henrique Ferreiro <henrique.ferreiro@...>
From: Joshua Nichols <nichoj@g.o>
Subject: Re: [migration] problems with eclipse-{cdt,pydev}
Date: Fri, 14 Apr 2006 11:31:06 -0400
Henrique Ferreiro wrote:
> When trying to install any of them I get this several times along the
> compilation phase:
>
> ACCESS DENIED  unlink:    /usr/share/javatoolkit/pym/parser/helpers.pyc
> ACCESS DENIED
> unlink:    /usr/share/javatoolkit/pym/parser/buildproperties.pyc
> ACCESS DENIED  unlink:    /usr/share/javatoolkit/pym/parser/tree.pyc
> ACCESS DENIED  unlink:    /usr/share/javatoolkit/pym/parser/parser.pyc
> ACCESS DENIED  unlink:    /usr/share/javatoolkit/pym/parser/manifest.pyc
>
> Finally it fails with:
>
> --------------------------- ACCESS VIOLATION SUMMARY
> ---------------------------LOG FILE =
> "/var/log/sandbox/sandbox-dev-eclipse_-_eclipse-cdt-3.0.0-23411.log"
>
> unlink:    /usr/share/javatoolkit/pym/parser/__init__.pyc
> unlink:    /usr/share/javatoolkit/pym/parser/helpers.pyc
> unlink:    /usr/share/javatoolkit/pym/parser/buildproperties.pyc
> unlink:    /usr/share/javatoolkit/pym/parser/tree.pyc
> unlink:    /usr/share/javatoolkit/pym/parser/parser.pyc
> unlink:    /usr/share/javatoolkit/pym/parser/manifest.pyc
> unlink:    /usr/share/javatoolkit/pym/parser/__init__.pyc
> unlink:    /usr/share/javatoolkit/pym/parser/helpers.pyc
> unlink:    /usr/share/javatoolkit/pym/parser/buildproperties.pyc
> unlink:    /usr/share/javatoolkit/pym/parser/tree.pyc
> unlink:    /usr/share/javatoolkit/pym/parser/parser.pyc
> unlink:    /usr/share/javatoolkit/pym/parser/manifest.pyc
> unlink:    /usr/share/javatoolkit/pym/parser/__init__.pyc
> unlink:    /usr/share/javatoolkit/pym/parser/helpers.pyc
> unlink:    /usr/share/javatoolkit/pym/parser/buildproperties.pyc
> unlink:    /usr/share/javatoolkit/pym/parser/tree.pyc
> unlink:    /usr/share/javatoolkit/pym/parser/parser.pyc
> unlink:    /usr/share/javatoolkit/pym/parser/manifest.pyc
> ...
> --------------------------------------------------------------------------------
>
>   
Try running any of the scripts from javatoolkit outside of an emerge,
like /usr/bin/class-version-verify.py or /usr/bin/xml-rewrite.py .

Ideally, these .pyc files should be created at merge time of
javatoolkit. Unfortunately, not being a python guy, I have no idea how
to make this happen.

- Josh
-- 
gentoo-java@g.o mailing list


References:
[migration] problems with eclipse-{cdt,pydev}
-- Henrique Ferreiro
Navigation:
Lists: gentoo-java: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
[migration] problems with eclipse-{cdt,pydev}
Next by thread:
[migration] eclipse-pydev version
Previous by date:
[migration] problems with eclipse-{cdt,pydev}
Next by date:
[migration] eclipse-pydev version


Updated Jun 17, 2009

Summary: Archive of the gentoo-java mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.