Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-java
Navigation:
Lists: gentoo-java: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-java@g.o
From: Jon Severinsson <jon@...>
Subject: Re: Online-banking on 64Bit system needs Sun-Java
Date: Tue, 21 Mar 2006 16:37:02 +0100
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Yes, I know. I use sun-jdk-1.5 myself (as generation 2 system vm [1]) as
well as blackdown-jdk-1.4 (as generation 1 system vm and nsplugin).
However sun-{jdk,jre} for amd64 does not include a nsplugin (applet
support), so it won't work for online-banking. For that you'll need
either blackdown-{jdk,jre} (not yet available in 1.5 version), or a
manually installed 32-bit sun-{jdk,jre}.

As for jre vs. jdk you are right. It's just that as portage requires you
to have a jdk to emerge java programs/libraries anyway I find it
convenient to just install jdks. That's just a personal opinion though.

[1] https://projects.gentooexperimental.org/expj/wiki/

Joshua Nichols skrev:
> You know, there is a 64 bit version of sun-jdk-1.5... Before unmasking
> and installing, please be sure to read
> http://www.gentoo.org/proj/en/java/tiger-faq.xml about the concerns of
> using a 1.5 jdk. If you don't need the development tools (ie
> compiler), you can also try sun-jre-bin-1.5.
>
> Jon Severinsson wrote:
>> Blackdown java is based on sun java sources, and has a ns-plugin, so
>> it'll work (unless they require java 1.5, in which case you'll have
>> to manually install the 32 bit version of sun-jdk-1.5).
>>
>> Stephan Palm skrev:
>>> I'm trying to install a java-plugin for firefox on a 64Bit system
>>> in order to be able to do online-banking. It has to be sun-java,
>>> since that is the one required by the bank. Does anyone have any
>>> suggestions on that?
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFEIB2eOOpxqcksWu4RAr9eAJ4xswVlucYJWoLhfWDapt9vblG8XgCfXPSr
sncohEjbzO9vxQesoUfEkP4=
=IA4d
-----END PGP SIGNATURE-----
-- 
gentoo-java@g.o mailing list


References:
Online-banking on 64Bit system needs Sun-Java
-- Stephan Palm
Re: Online-banking on 64Bit system needs Sun-Java
-- Jon Severinsson
Re: Online-banking on 64Bit system needs Sun-Java
-- Joshua Nichols
Navigation:
Lists: gentoo-java: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: Online-banking on 64Bit system needs Sun-Java
Next by thread:
Re: Online-banking on 64Bit system needs Sun-Java
Previous by date:
Re: Online-banking on 64Bit system needs Sun-Java
Next by date:
Tomcat 5.5.16


Updated Jun 17, 2009

Summary: Archive of the gentoo-java mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.