Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-java
Navigation:
Lists: gentoo-java: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-java@g.o
From: Miroslav Šulc <miroslav.sulc@...>
Subject: Tomcat 5.5.16
Date: Sun, 26 Mar 2006 15:37:41 +0200
Hi,

did someone succeed with building of Tomcat 5.5.16 from java
experimental overlay? I get error while building tomcat-util:

[javac]    133.     protected Collection<? extends CRL> getCRLs(String crlf)
    [javac]                                 ^-------------^
    [javac] *** Semantic Error: Using type arguments to access generic
types requires the use of "-source 1.5" or greater. Compilation will
continue using the raw type "java.util.Collection", but no class file
will be emitted.(not yet implemented)


    [javac]    140.         Collection<? extends CRL> crls = null;
    [javac]                           ^-------------^
    [javac] *** Semantic Error: Using type arguments to access generic
types requires the use of "-source 1.5" or greater. Compilation will
continue using the raw type "java.util.Collection", but no class file
will be emitted.(not yet implemented)

BUILD FAILED
/var/tmp/portage/tomcat-5.5.16/work/apache-tomcat-5.5.16-src/build.xml:49:
The following error occurred while executing this line:
/var/tmp/portage/tomcat-5.5.16/work/apache-tomcat-5.5.16-src/build/build.xml:584:
The following error occurred while executing this line:
/var/tmp/portage/tomcat-5.5.16/work/apache-tomcat-5.5.16-src/build/build.xml:188:
The following error occurred while executing this line:
/var/tmp/portage/tomcat-5.5.16/work/apache-tomcat-5.5.16-src/connectors/util/build.xml:75:
Compile failed; see the compiler error output for details.

Total time: 32 seconds

!!! ERROR: www-servers/tomcat-5.5.16 failed.
Call stack:
  ebuild.sh, line 1526:   Called dyn_compile
  ebuild.sh, line 923:   Called src_compile
  tomcat-5.5.16.ebuild, line 130:   Called die

!!! compile failed
!!! If you need support, post the topmost build error, and the call
stack if relevant.

!!! When you filing a bug report, please include the following information:
GENTOO_VM(sun-jdk-1.5)  CLASSPATH() JAVA_HOME(/opt/sun-jdk-1.5.0.06)
JAVACFLAGS(-source 1.5 -target 1.5) COMPILER()

I am not a pro but it seems to me that JAVACFLAGS are not applied. I
have migration and axxo overlay installed.

-- 
Miroslav Šulc

Attachment:
miroslav.sulc.vcf (Vcard)
Replies:
Re: Tomcat 5.5.16
-- Wiktor Wandachowicz
Navigation:
Lists: gentoo-java: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Online-banking on 64Bit system needs Sun-Java
Next by thread:
Re: Tomcat 5.5.16
Previous by date:
Re: Online-banking on 64Bit system needs Sun-Java
Next by date:
Re: Online-banking on 64Bit system needs Sun-Java


Updated Aug 22, 2011

Summary: Archive of the gentoo-java mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.