Gentoo Archives: gentoo-kernel

From: Peter Volkov <pva@g.o>
To: gentoo-kernel@l.g.o
Subject: Re: [gentoo-kernel] virtual/linux-sources-2.6
Date: Mon, 25 Jul 2011 04:03:28
Message-Id: 1311540702.16903.9.camel@tablet
In Reply to: Re: [gentoo-kernel] virtual/linux-sources-2.6 by Ulrich Mueller
В Вск, 24/07/2011 в 17:20 +0200, Ulrich Mueller пишет:
> >>>>> On Sat, 23 Jul 2011, Stratos Psomadakis wrote: > > On 07/23/2011 07:09 PM, Krzysztof Pawlik wrote: > >> Currently virtual/linux-sources-2.6 depends on sys-kernel/foo-2.6*, > >> should we create virtual/linux-sources-3.0 (and start fixing > >> ebuilds depending on =virtual/linux-sources-2.6) or just change > >> virtual/linux-sources-2.6 to depend on >=2.6 ? Opinions? > > Currently version 3.0 is only available with vanilla-sources and > gentoo-sources. Therefore the problem is that virtual/linux-sources-3 > would pull in one of these even for users of other *-sources (e.g. > hardened). > > On the other hand, allowing versions 3.* as dependency of > virtual/linux-sources-2.6 might be confusing. > > Therefore, my suggestion would be as follows: > 1. Temporarily change the dependency in virtual/linux-sources-2.6 > to >=2.6 in order to resolve the current issues with dependencies. > 2. Later, when most of *-sources are available in version 3.*, revert > linux-sources-2.6 to the current dependency and create > virtual/linux-sources-3. (I think the version should be just 3 and > not 3.0, unless you want a virtual for 3.0, 3.1, etc.)
What are the benefits here?
> Or, a completely different approach: Drop the versioning of the > virtual altogether and have only virtual/linux-sources-0. (This might > cause some minor problems for users of 2.4 profiles, but I'd guess > that the remaining users are experienced enough to handle that.)
And what are the benefits here? It's better to fix what's broken part and avoid fixing something that works... -- Peter.