Gentoo Archives: gentoo-kernel

From: Krzysztof Pawlik <nelchael@g.o>
To: gentoo-kernel@l.g.o
Subject: Re: [gentoo-kernel] virtual/linux-sources-2.6
Date: Sun, 24 Jul 2011 16:03:39
Message-Id: 4E2C3F33.705@gentoo.org
In Reply to: Re: [gentoo-kernel] virtual/linux-sources-2.6 by Ulrich Mueller
On 24/07/11 17:20, Ulrich Mueller wrote:
>>>>>> On Sat, 23 Jul 2011, Stratos Psomadakis wrote: > >> On 07/23/2011 07:09 PM, Krzysztof Pawlik wrote: >>> Currently virtual/linux-sources-2.6 depends on sys-kernel/foo-2.6*, >>> should we create virtual/linux-sources-3.0 (and start fixing >>> ebuilds depending on =virtual/linux-sources-2.6) or just change >>> virtual/linux-sources-2.6 to depend on >=2.6 ? Opinions? > > Currently version 3.0 is only available with vanilla-sources and > gentoo-sources. Therefore the problem is that virtual/linux-sources-3 > would pull in one of these even for users of other *-sources (e.g. > hardened).
Yes.
> On the other hand, allowing versions 3.* as dependency of > virtual/linux-sources-2.6 might be confusing. > > Therefore, my suggestion would be as follows: > 1. Temporarily change the dependency in virtual/linux-sources-2.6 > to >=2.6 in order to resolve the current issues with dependencies. > 2. Later, when most of *-sources are available in version 3.*, revert > linux-sources-2.6 to the current dependency and create > virtual/linux-sources-3. (I think the version should be just 3 and > not 3.0, unless you want a virtual for 3.0, 3.1, etc.) > > Or, a completely different approach: Drop the versioning of the > virtual altogether and have only virtual/linux-sources-0. (This might > cause some minor problems for users of 2.4 profiles, but I'd guess > that the remaining users are experienced enough to handle that.)
What about going with #1 and let's fix the description in virtual/linux-sources-2.6 to clearly state that it's '2.6 or newer' -- that could solve the issue at hand and also not confuse everyone. In the long run I'm in favour of dropping the version from virtual, but this will be possible when 2.4 is deprecated and removed. Otherwise it's problematic. -- Krzysztof Pawlik <nelchael at gentoo.org> key id: 0xF6A80E46 desktop-misc, java, vim, kernel, python, apache...

Attachments

File name MIME type
signature.asc application/pgp-signature