Gentoo Archives: gentoo-laptop

From: Jordi Molina <warp3r@×××××.com>
To: gentoo-laptop@l.g.o
Subject: Re: [gentoo-laptop] sound issues
Date: Tue, 19 Apr 2005 13:46:01
Message-Id: 647a4058050419064670b5227a@mail.gmail.com
In Reply to: Re: [gentoo-laptop] sound issues by ian douglas
Hi,

Just two questions,
- you have the problem as a regular user, as root, or always?
- Do you use udev?




On 4/18/05, ian douglas <id@×××.us> wrote:
> > What does your config files look like? > > root@laptop > cat /etc/modules.d/alsa > # Alsa 0.9.X kernel modules' configuration file. > # $Header: > /var/cvsroot/gentoo-x86/media-sound/alsa-utils/files/alsa-modules.conf-rc,v > 1.4 > 2004/11/16 01:31:22 eradicator Exp $ > > # ALSA portion > # OSS/Free portion > > ## > ## IMPORTANT: > ## You need to customise this section for your specific sound card(s) > ## and then run `update-modules' command. > ## Read alsa-driver's INSTALL file in /usr/share/doc for more info. > ## > ## ALSA portion > ## alias snd-card-0 snd-interwave > ## alias snd-card-1 snd-ens1371 > ## OSS/Free portion > ## alias sound-slot-0 snd-card-0 > ## alias sound-slot-1 snd-card-1 > ## > > # OSS/Free portion - card #1 > ## OSS/Free portion - card #2 > ## alias sound-service-1-0 snd-mixer-oss > ## alias sound-service-1-3 snd-pcm-oss > ## alias sound-service-1-12 snd-pcm-oss > > alias /dev/mixer snd-mixer-oss > alias /dev/dsp snd-pcm-oss > alias /dev/midi snd-seq-oss > > # Set this to the correct number of cards. > # --- BEGIN: Generated by ALSACONF, do not edit. --- > # --- ALSACONF verion 1.0.8 --- > alias snd-card-0 snd-ali5451 > alias sound-slot-0 snd-ali5451 > # --- END: Generated by ALSACONF, do not edit. --- > > emerge matches in 'world' file for 'alsa': > > root@laptop > grep 'alsa' /var/lib/portage/world > media-sound/alsa-tools > media-plugins/xmms-alsa > media-libs/alsa-lib > media-sound/alsa-headers > > root@laptop > lspci | grep 5451 > 0000:00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link > Controller Audio Device (rev 02) > > root@laptop > lsmod | grep "snd_" > snd_pcm_oss 60192 0 > snd_mixer_oss 20736 1 snd_pcm_oss > snd_seq_oss 35584 0 > snd_seq_midi_event 7168 1 snd_seq_oss > snd_seq 57104 4 snd_seq_oss,snd_seq_midi_event > snd_seq_device 8460 2 snd_seq_oss,snd_seq > snd_ali5451 21956 0 > snd_ac97_codec 77944 1 snd_ali5451 > snd_pcm 96772 3 snd_pcm_oss,snd_ali5451,snd_ac97_codec > snd_timer 24324 2 snd_seq,snd_pcm > snd 54756 9 > snd_pcm_oss,snd_mixer_oss,snd_seq_oss,snd_seq,snd_seq_device,snd_ali5451,snd_ac97_codec,snd_pcm,snd_timer > snd_page_alloc 9220 1 snd_pcm > > root@laptop > grep 5451 .config > CONFIG_SND_ALI5451=m > > root@laptop > rc-update show default | grep alsa > alsasound | default > > Anything else I can show from my configuration to track this down? > > -- > Ian Douglas > http://www.w98.us/ > > -- > gentoo-laptop@g.o mailing list > >
-- Jordi Molina Casas (warp3r) mail: warp3r@×××××.com www: www.warp3r.com If you're still sending mail to warper@eresmas, please update your address book, my current email is warp3r@×××××.com -- gentoo-laptop@g.o mailing list

Replies

Subject Author
Re: [gentoo-laptop] sound issues ian douglas <id@×××.us>