Gentoo Archives: gentoo-laptop

From: Spencer McGuire <spencerm@××××××××××.net>
To: gentoo-laptop@l.g.o, henri.magnin@××××.net
Subject: RE: [gentoo-laptop] Basic??? problem to use Portage ?
Date: Wed, 03 Nov 2004 20:49:46
Message-Id: E1CPS4H-0005Mp-00@gronouski.mail.atl.earthlink.net
In Reply to: [gentoo-laptop] Basic??? problem to use Portage ? by Henri Magnin
You need to read on how to install GRP packages, here is how to do it:
Code Listing 3: Mount the Packages CD
 
(Put the Gentoo Packages CD in the CD tray)
# mount /mnt/cdrom

 

Now configure Portage to use /mnt/cdrom for its prebuilt packages: 

Code Listing 4: Configuring Portage to use /mnt/cdrom
 
# ls /mnt/cdrom

(If there is a /mnt/cdrom/packages directory:)
# export PKGDIR="/mnt/cdrom/packages"

(Otherwise:)
# export PKGDIR="/mnt/cdrom"

Now install the packages you want. The Packages CD contains several prebuilt
binaries, for instance KDE: 

Code Listing 5: Installing KDE
 
# emerge --usepkg kde

You should now be able to use emerge --usepkg gnome instead of kde as shown
above, and you can install any packages that are on the cdrom.

-----Original Message-----
From: Henri Magnin [mailto:henri.magnin@××××.net] 
Sent: Wednesday, November 03, 2004 1:25 PM
To: gentoo-laptop@l.g.o
Subject: [gentoo-laptop] Basic??? problem to use Portage ?

Hi

I successfully installed Gentoo on a recent ASUS laptop (the basic install, 
as described in the handbook).

I cannot use the on-line features of Portage since I only have a slow modem 
at home.
So, I used an universal boot CD, started from a stage 3 tarball (all this 
downloaded from my job office location).... But also expected to have a 
graphical environment (let's say Gnome, but I have the same kind of problem 
with Kde).

Initially, I saw that issuing the "emerge gnome" command required to have 
some ebuilds which were not present on my PC.

...So, I downloaded an ISO image of the relevant "package CD" from my job 
(with a fast-speed connection). I burned the image as a CD, and installed
its 
contents as follows :
- I copied all files from the "All" subdirectory of the CD in my 
/usr/portage/distfiles folder (a lot of non-zero-length '.tbz2' files)
- I did not deal with files in other sub-directories, since all these
'.tbz2' 
files were zero-length

The problem when I "emerge gnome" is that it tries to download the 
"gnome-mime-data-2.4.1.tar.bz2" file from many WWW locations, and fails (of 
course, I am not connected, and would like to install offline).

...This while, the file "gnome-mime-date-2.4.1.tbz2" is really (and with 
non-zero length) in my /usr/portage/distfiles folder !

What did I do wrong ? Think I misunderstanded Portage, but where ?

Thanks by advance
Regards
Henri

--
gentoo-laptop@g.o mailing list


--
gentoo-laptop@g.o mailing list

Replies

Subject Author
Re: [gentoo-laptop] Basic??? problem to use Portage ? Henri Magnin <henri.magnin@××××.net>