Gentoo Archives: gentoo-laptop

From: Mark Thompson <mark@×××××××××××××.ca>
To: gentoo-laptop@l.g.o
Subject: RE: [gentoo-laptop] 855gm - xorg - no 1024x768
Date: Tue, 26 Apr 2005 12:51:29
Message-Id: 200504261251.j3QCpTpn022587@robin.gentoo.org
In Reply to: Re: [gentoo-laptop] 855gm - xorg - no 1024x768 by Jordi Molina
Hi, thank you for the response.

I removed the VGA section and still
	(II) I810(0): Not using mode "1024x768" (no mode of this name)


Here is my kernel config:

CONFIG_AGP=m
# CONFIG_AGP_ALI is not set
# CONFIG_AGP_ATI is not set
# CONFIG_AGP_AMD is not set
# CONFIG_AGP_AMD64 is not set
CONFIG_AGP_INTEL=m
CONFIG_AGP_INTEL_MCH=m
# CONFIG_AGP_NVIDIA is not set
# CONFIG_AGP_SIS is not set
CONFIG_DRM=m
# CONFIG_DRM_TDFX is not set
# CONFIG_DRM_R128 is not set
# CONFIG_DRM_RADEON is not set
CONFIG_DRM_I810=m
CONFIG_DRM_I830=m
CONFIG_DRM_I915=m
# CONFIG_DRM_MGA is not set
# CONFIG_DRM_SIS is not set
# CONFIG_MWAVE is not set
# CONFIG_RAW_DRIVER is not set
# CONFIG_HPET is not set
# CONFIG_HANGCHECK_TIMER is not set
CONFIG_FB=y					---- =no
CONFIG_FB_MODE_HELPERS=y
# CONFIG_FB_TILEBLITTING is not set
# CONFIG_FB_VGA16 is not set
CONFIG_FB_VESA=m
# CONFIG_FB_VESA_STD is not set
CONFIG_FB_VESA_TNG=y
CONFIG_FB_VESA_DEFAULT_MODE="800x600@60" --- 1024x768 does not work
CONFIG_VIDEO_SELECT=y
# CONFIG_FB_HGA is not set
# CONFIG_FB_RIVA is not set
CONFIG_FB_I810=m
CONFIG_FB_I810_GTF=y
CONFIG_FB_INTEL=m
CONFIG_FB_INTEL_DEBUG=y

Any other ideas I can try?
Saying my please and thank you's


mark







-----Original Message-----
From: Jordi Molina [mailto:warp3r@×××××.com] 
Sent: Tuesday, April 26, 2005 6:32 AM
To: gentoo-laptop@l.g.o
Subject: Re: [gentoo-laptop] 855gm - xorg - no 1024x768

Hi,
FOA, if you have i855GM ensure that you have compiled the i915 DRI
module on the kernel.

and get rid of this part

Section "Device"

    Identifier  "Standard VGA"

    VendorName  "Unknown"

    BoardName   "Unknown"

    Driver     "vga"

EndSection


cheers
Jordi



On 4/25/05, Mark Thompson <mark@×××××××××××××.ca> wrote:
> > > Hello > > > > I have been trying to get 1024x768 on my Gateway PoS for a while now. > > > > Here is parts of Xorg.0.log > > > > gentoo root # grep 1024 /var/log/Xorg.0.log > > > > (II) I810(0): Integrated Graphics Chipset: Intel(R) 852GM > > (--) I810(0): Chipset: "852GM/855GM" > > (--) I810(0): Linear framebuffer at 0xE8000000 > > (--) I810(0): IO registers at addr 0xE0000000 > > (II) I810(0): 2 display pipes available. > > (II) I810(0): detected 8060 kB stolen memory. > > (II) I810(0): I830CheckAvailableMemory: 697340 kB available > > (II) I810(0): Checking Lid status enabled > > (II) I810(0): Will attempt to tell the BIOS that there is
12288
> kB VideoRAM > > (WW) I810(0): Extended BIOS function 0x5f11 not supported. > > (II) I810(0): Display Info: LFP (local flat panel): attached: > TRUE, present: TRUE, size: (1024,768) > > (II) I810(0): Size of device LFP (local flat panel) is 1024 x > 768 > > (II) I810(0): Lowest common panel size for pipe B is 1024 x
768
> > (II) I810(0): PanelID returned panel resolution : 1024x768 > > > > Mode: 45 (1024x768) > > Mode: 47 (1024x600) > > > > (II) I810(0): Not using mode "1024x768" (no mode of this name) > > (II) I810(0): Increasing the scanline pitch to allow tiling
mode
> (800 -> 1024). > > (--) I810(0): Virtual size is 800x600 (pitch 1024) > > > > > > > > Here is my xorg.conf - Modelines generated from > ddcxinfo-knoppix > > ----------------------------------------------------------------------- > > gentoo root # more /etc/X11/xorg.conf > > Section "Module" > > Load "dbe" # Double buffer extension > > SubSection "extmod" > > Option "omit xfree86-dga" # don't initialise the DGA extension > > EndSubSection > > Load "type1" > > Load "freetype" > > # This loads the GLX module > > # Load "glx" > > # This loads the DRI module > > Load "dri" > > EndSection > > Section "Files" > > RgbPath "/usr/X11R6/lib/X11/rgb" > > FontPath "/usr/share/fonts/misc/" > > FontPath "/usr/share/fonts/TTF/" > > FontPath "/usr/share/fonts/Type1/" > > # FontPath "/usr/share/fonts/CID/" > > FontPath "/usr/share/fonts/75dpi/" > > FontPath "/usr/share/fonts/100dpi/" > > FontPath "/usr/share/fonts/local/" > > # FontPath "/usr/share/fonts/Speedo/" > > # FontPath "/usr/share/fonts/TrueType/" > > # FontPath "/usr/share/fonts/freefont/" > > # ModulePath "/usr/X11R6/lib/modules" > > EndSection > > Section "ServerFlags" > > > > EndSection > > > > Section "InputDevice" > > Identifier "Keyboard1" > > Driver "kbd" > > Option "AutoRepeat" "500 30" > > Option "XkbRules" "xorg" > > Option "XkbModel" "pc101" > > Option "XkbLayout" "us" > > EndSection > > Section "InputDevice" > > Identifier "Mouse1" > > Driver "mouse" > > Option "Protocol" "Auto" > > Option "Device" "/dev/input/mouse0" > > EndSection > > > > Section "Device" > > Identifier "Standard VGA" > > VendorName "Unknown" > > BoardName "Unknown" > > Driver "vga" > > EndSection > > Section "Device" > > Identifier "** Intel i810 (generic) [i810]" > > Driver "i810" > > # VideoRam 16384 > > # Insert Clocks lines here if appropriate > > EndSection > > > > Section "Screen" > > Identifier "Screen 1" > > Device "** Intel i810 (generic) [i810]" > > Monitor "Monitor0" > > DefaultDepth 16 > > Subsection "Display" > > Depth 16 > > Modes "1024x768" > > ViewPort 0 0 > > # Virtual 1280 1024 > > EndSubsection > > EndSection > > > > Section "ServerLayout" > > Identifier "Simple Layout" > > Screen "Screen 1" > > InputDevice "Mouse1" "CorePointer" > > InputDevice "Keyboard1" "CoreKeyboard" > > EndSection > > > > # Section "DRI" > > # Mode 0666 > > # EndSection > > > > Section "Monitor" > > Identifier "Monitor0" > > # HorizSync 28.0 - 78.0 # Warning: This may fry very old Monitors > > HorizSync 28.0 - 96.0 # Warning: This may fry old Monitors > > VertRefresh 50.0 - 75.0 # Very conservative. May flicker. > > # VertRefresh 50.0 - 62.0 # Extreme conservative. Will flicker. TFT > default. > > # Default modes distilled from > > # "VESA and Industry Standards and Guide for Computer Display > Monitor > > # Timing", version 1.0, revision 0.8, adopted September 17, > 1998. > > # $XFree86: > xc/programs/Xserver/hw/xfree86/etc/vesamodes,v 1.4 > 1999/11/18 16:52:17 tsi Exp $ > > # 1024x768i @ 43Hz (industry standard) hsync: 35.5kHz > > ModeLine "1024x768" 44.9 1024 1032 1208 1264 768 768 776
817
> +hsync +vsync Interlace > > # 1024x768 @ 60Hz (VESA) hsync: 48.4kHz > > ModeLine "1024x768" 65.0 1024 1048 1184 1344 768 771 777
806
> -hsync -vsync > > # 1024x768 @ 70Hz (VESA) hsync: 56.5kHz > > ModeLine "1024x768" 75.0 1024 1048 1184 1328 768 771 777
806
> -hsync -vsync > > # 1024x768 @ 75Hz (VESA) hsync: 60.0kHz > > ModeLine "1024x768" 78.8 1024 1040 1136 1312 768 769 772
800
> +hsync +vsync > > # 1024x768 @ 85Hz (VESA) hsync: 68.7kHz > > ModeLine "1024x768" 94.5 1024 1072 1168 1376 768 769 772
808
> +hsync +vsync > > # 1024x768 @ 100.00 Hz (GTF) hsync: 81.40 kHz; pclk: 113.31 MHz > > ModeLine "1024x768" 113.31 1024 1096 1208 1392 768 769 772 814 > -HSync +Vsync > > -------------------------------------------------------------- > > > > > > I have tried i915linux.tar.bz2 and i810linux.tar.bz2 from www.intel.com > > > > I tried the 855resolution patch (version 1,2 and 3) from Alain Poirier > > > > I tried a modified 1280patch based on 855resolution > > > > knoppix/slax livecds only give 800x600 > > > > can anyone help me get 1024x768 on this , i'm stuck in XP until I do. > > > > thanks > > mark > >
-- Jordi Molina Casas (warp3r) mail: warp3r@×××××.com www: www.warp3r.com If you're still sending mail to warper@eresmas, please update your address book, my current email is warp3r@×××××.com -- gentoo-laptop@g.o mailing list -- gentoo-laptop@g.o mailing list

Replies

Subject Author
Re: [gentoo-laptop] 855gm - xorg - no 1024x768 "Francisco Figueiredo Jr." <fxjrlists@×××××××××.br>