Gentoo Archives: gentoo-laptop

From: Joaquim Quinteiro Uchoa <joaquim.uchoa@×××××.com>
To: gentoo-laptop@l.g.o
Subject: Re: [gentoo-laptop] Ethernet not starting...
Date: Thu, 26 Apr 2007 18:08:06
Message-Id: 59541ff30704261106y93de887i1de9e98a3e556e5a@mail.gmail.com
In Reply to: Re: [gentoo-laptop] Ethernet not starting... by mail
Good,

This took me a complete day recompiling kernel here, I was thinking
in problem with Xen or some package... Tried several options of kernel,
till found eth5 with ip addr... Looked in Google e found the answer in a
Gentoo forum.

One day lost and it was only a little file...

2007/4/26, mail <lists@×××××.net>:
> On Thu, 2007-04-26 at 10:35 -0300, Joaquim Quinteiro Uchoa wrote: > > If this instalation was used in another machine, or you have another net device, > > udev can be putting your broadcom as another number (eth2, ...) > > > > Try > > ifconfig -a > > or > > ip addr > > to get all interfaces on your system > > > > If the problem is the wrong id on eth, remove > > /etc/udev/rules.d/70-persistent-net.rules > > > > And udev will recreate automaticaly again. > > > > 2007/4/26, mail <lists@×××××.net>: > > > Hi, I know this sounds bad, I must be missing something really easy > > > here. I can't seem to start my ethernet interface... > > > > > > I have a Thinkpad T43 > > > lspci shows: > > > Broadcom NetXtreme BCM5751M Gigabit PCI Express card > > > > > > I loaded the Tigon3 kernel module > > > dmesg shows: > > > eth0: Tigon3... with a mac address > > > > > > I have a simple setup in conf.d/net of just config_eth0= ( "dhcp" ) > > > however, when I try to start it, I get the following error: > > > > > > /etc/init.d/net.eth0 start, I get: > > > * Caching service dependencies ... [ ok ] > > > * Starting eth0 > > > * Bringing up eth0 > > > * dhcp > > > * network interface eth0 does not exist > > > * Please verify hardware or kernel module (driver) [ !! ] > > > > > > > > > If I boot with a knoppix live CD, the Interface fires up fine, so I know > > > it is supported... > > > > > > What am I missing? > > > Thanks! > > > rick > > > > > > > > > > > > -- > > > gentoo-laptop@g.o mailing list > > > > > > > > > > > > -- > > []s > > Joaquim > > ------------------------------------------ > > (o_ Joaquim Quinteiro Uchoa > > //\ Consultor Linux e EaD > > U_/_ Linux User # 100534 > > ------------------------------------------ > > > That was it! > Thanks > rick > > > > > -- > gentoo-laptop@g.o mailing list > >
-- []s Joaquim ------------------------------------------ (o_ Joaquim Quinteiro Uchoa //\ Consultor Linux e EaD U_/_ Linux User # 100534 ------------------------------------------ -- gentoo-laptop@g.o mailing list