Gentoo Archives: gentoo-laptop

From: Mark Thompson <mark@×××××××××××××.ca>
To: gentoo-laptop@l.g.o
Subject: RE: [gentoo-laptop] 855gm - xorg - no 1024x768
Date: Fri, 27 May 2005 13:14:35
Message-Id: 200505271314.j4RDEYwQ032762@robin.gentoo.org
In Reply to: Re: [gentoo-laptop] 855gm - xorg - no 1024x768 by "Francisco Figueiredo Jr."
Thank you for the reply,

I have tried the 855resolution program.
	Chipset: 855GM
	VBIOS type: 1
	VBIOS Version: 2880
	Here is the output of version 0.2 for 1024x768

	Mode 34 : 1024x768, 8 bits/pixel
  	(Modeline : 65000 1024 1047 1183 1343 600 697 704 805)
  	(Modeline : 78750 1024 1039 1135 1311 600 692 696 799)
  	(Modeline : 94500 1024 1071 1167 1375 600 692 696 807)


	Mode 45 : 1024x768, 16 bits/pixel
  	(Modeline : 65000 1024 1047 1183 1343 600 697 704 805)
  	(Modeline : 78750 1024 1039 1135 1311 600 692 696 799)
  	(Modeline : 94500 1024 1071 1167 1375 600 692 696 807)

	Mode 54 : 1024x768, 32 bits/pixel
  	(Modeline : 65000 1024 1047 1183 1343 600 697 704 805)
  	(Modeline : 78750 1024 1039 1135 1311 600 692 696 799)
  	(Modeline : 94500 1024 1071 1167 1375 600 692 696 807)

	Version 0.4 gives the same without the mode lines



Based on these modelines would anyone be able to tell me the proper modeline
for xorg.conf? I have tried -

 Modeline  "1024x768" 75.0 1024 1048 1184 1328 768 771 777 806 -hsync -vsync
 ModeLine  "1024x768" 65.0 1024 1048 1184 1344 768 779 785 806
 ModeLine  "1024x768" 65.0 1024 1047 1183 1343 600 697 704 805
 (And a crap load of others)

I can't find anything more out about the LCD screen in the laptop but XP
reports
	Vertical Refresh = 60Hz at 1024x768 32bit
	Font Resolution = 96dpi

Gateway M305CRV (do not but Gateway)
Thanks 
Mark



-----Original Message-----
From: Francisco Figueiredo Jr. [mailto:fxjrlists@×××××××××.br] 
Sent: Thursday, May 26, 2005 5:16 PM
To: gentoo-laptop@l.g.o
Subject: Re: [gentoo-laptop] 855gm - xorg - no 1024x768

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Mark Thompson wrote:
> Hi, thank you for the response. > > I removed the VGA section and still > (II) I810(0): Not using mode "1024x768" (no mode of this name) > >
Hi Mark. This problems is caused because your bios doesn't list the 1024x768 video mode and i810 driver needs it listed to enable the mode. To workaround, you will need the 855resolution: http://perso.wanadoo.fr/apoirier/ This utility enable you to *write* an specific resolution mode to your in-memory copy of bios so driver is able to find it. I'm using it here right now to be able to use my native 1400x1050 resolution. It is very simple to build. Also, you will need to make it run everytime you boot as the info is lost when shutdown. I added it to my /etc/conf.d/local.start: /usr/sbin/855resolution 3c 1400 1050 > /dev/null The 3c is an unused slot where I can store my configuration. Have a look at readme inside the tar.gz file to know how it works. I hope it helps. - -- Regards, Francisco Figueiredo Jr. Npgsql Lead Developer http://gborg.postgresql.org/project/npgsql MonoBrasil Project Founder Member http://monobrasil.softwarelivre.org - ------------- "Science without religion is lame; religion without science is blind." ~ Albert Einstein -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.2.6 (GNU/Linux) Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org iQEVAwUBQpY8mv7iFmsNzeXfAQJAVgf/SHTSPFtIATX9FRwX5sS0e2jCFuA4UD6q IOtB1r2ut4fxiMkATH7MamZi3idMoj2j2EOhDFqJ2SMtRENNmjr0dwWgms+kGr1h KdaO7jjLg1QEvEGyJLGVORI28leeeLRMX01dqvnShuBbUDvEmB7ibmCfba3r+b0u vxiIO9X94S9PI9aM5arHd7arUFLbKbT/kg7oTEtFWgAJ48LMlX6Y5AZq8bIbJAy/ +ocknpP4gAnxJPbuMAGGUNNfK9L/ttb5Fl7E8bgMr1bM/iZ3H+eDz4sRs9d5q2EU j8TvRWniu2DC4uFjJgOrA8ugx62xZsTXGN6MTi8cdnUf2jjcbrJ1aw== =iAK+ -----END PGP SIGNATURE----- ____________________________________________________ Yahoo! Mail, cada vez melhor: agora com 1GB de espaço grátis! http://mail.yahoo.com.br -- gentoo-laptop@g.o mailing list -- gentoo-laptop@g.o mailing list