Gentoo Archives: gentoo-laptop

From: Cliff Rowley <cliffrowley@×××××.com>
To: gentoo-laptop@l.g.o
Subject: [gentoo-laptop] swsusp2 *hang* :(
Date: Tue, 17 May 2005 08:46:06
Message-Id: 90fac657050517014644c7de7@mail.gmail.com
Morning folks :)

I've successfully patched my kernel (2.6.11-gentoo-r8) with software
suspend 2, and I just about have it working.  However after deciding
to give it a rest for the night and write some code, I pulled my T40
off of its docking station and it hung completely (no response at all,
not even keyboard lights).  At first I thought this might be an issue
with switching from AC to DC whilst running, so I hard reset the
machine and booted from cold on DC, but it hung again.  In fact, with
swsusp2 in my kernel, I cannot run on DC at all!

I did some research, and found these:

https://bugzilla.ubuntu.com/show_bug.cgi?id=6108
https://bugzilla.ubuntu.com/show_bug.cgi?id=7612

It was recommended in these posts to try disabling laptop_mode, which
I did - but to no avail.  Does anyone have software suspend running
properly on an IBM T* laptop?  Or has anyone come across these
problems before and found some way to solve it?  I'm not using madwifi
as some people in these posts are doing - but I am using ndiswrapper
with the bcmwl5 driver (I have a Buffalo G54 cardbus wireless card).

I don't know what to do next to try to figure it out.  If I can't
figure something today I'll just compile an alternative kernel without
swsusp2 for the time being - but I'd really like to figure this out if
possible.

Thanks :)

-- 
gentoo-laptop@g.o mailing list

Replies

Subject Author
Re: [gentoo-laptop] swsusp2 *hang* :( Andrew Randles <ehud42@×××××.com>