Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-laptop
Navigation:
Lists: gentoo-laptop: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: <gentoo-laptop@g.o>, <henri.magnin@...>
From: "Spencer McGuire" <spencerm@...>
Subject: RE: Trying Gentoo linux on a new Asus M6 laptop
Date: Sat, 23 Oct 2004 21:50:49 -0600
Maybe you should have found out what hardware was in your computer before
linux install, it is always helpful to have a full list of hardware when
dealing with a laptop, and knowing which modules/ drivers you need for
everything, I have had my troubles with linux but just stuck it through till
the end, when everything is working great. BTW, I have a tablet pc, you
thought a weekend was bad, try a month to get everything working.
Spencer

-----Original Message-----
From: Henri Magnin [mailto:henri.magnin@...] 
Sent: Saturday, October 23, 2004 4:07 AM
To: gentoo-laptop@g.o
Subject: Re: [gentoo-laptop] Trying Gentoo linux on a new Asus M6 laptop

Hi

Thanks for so quick and kind response.
I also had an e-mail from another person in the mailing list,
who suggested me to really reboot with my new kernel rather than
simply CHROOTing and checking what was available under /dev...

Indeed, the /dev/cdroms/cdrom0 appeared and was operational when I
really rebooted Gentoo from my hard disk.

But I now face other difficulties. I do not have any eth0 available, even
the
cable link one (I also have WiFi, but expected to configure this later).
Just 
'lo' appears in ifconfig...
I tried 'genkernel all' (rather than 'make menuconfig / make / make 
modules_install'), but eth0 is not recognized anymore; although the
'universal install' CD does (I really wonder how its kernel is built ;-)...

I think I will give up and move to a Suze with 2.6.x kernel since I did not
expect to spend a full week having an operational Linux on my machine.
- I think I will backup what I've done with Gentoo and come back to it later

on... -

Anyway, thanks again for your help.

Regards
Henri

Le Samedi 23 Octobre 2004 04:22, vous avez écrit :
> I'm not familiar with an ASUS laptop, but I know that a Sony VAIO has
> a firewire bus for the cdrom.  You might want to check to see if your
> cdrom is firewire or IDE.  When you use your gentoo boot CD, try lsmod
> and see if it is loading any special firewire drivers.  This might can
> help you find out.
>
> -Michael
>
>
> On Sat, 23 Oct 2004 00:19:08 +0200, Jaroslav Sladek
>
> <jaroslav.sladek@...> wrote:
> > On Fri, 22 Oct 2004 23:29:03 +0200, Henri Magnin <henri.magnin@...>

wrote:
> > > Hi
> > >
> > > I recently purchased an Asus M6 (Centrino 1.6GHz), and did not want to
> > > bother anymore with the Windoze Family stuff.
> > >
> > > I wanted to install a modular Linux, which I could master and upgrade
> > > as I like.
> > > I earlier tried muliple other distributions (Aurox, Mandrake), but I
> > > did no longer expect to have any "straightforward" or "magic" install
> > > which was too tricky to update in future.
> > >
> > > I downloaded Gentoo 2004.2, started from stage3 (in a first trial),
and
> > > compiled a 2.6.7 kernel.
> > >
> > > All was Ok, I even compiled X11 and kde and ati_drivers, to try employ
> > > at best my Radeon 9700 graphics card.
> > >
> > > My concern is about the CD-Rom on my own (very new) linux install.
> > > When booting from the install boot CD-Rom, I have a /dev/cdroms/cdrom0
> > > device.
> > >
> > > But in the /dev of my hard-disk install, there is no such entry. So
> > > when I chroot to it, I can no more see the CD-Rom device.
> >
> > You mean when you chroot to your harddisk after booting from CD?
> > That's not a big deal, since gentoo uses devfs (or udev) which gets
> > initialized during boot up sequence and actually creates all needed
> > devices in /dev of your root filesystem.
> >
> > But if I misunderstood you and you're not seeing you CD rom device in
> > /dev of your harddisk AFTER you booted your new kernel, then you
> > probably forget something in kernel config. Most likely, you should
> > have option "Include IDE/ATAPI CDROM support" checked under Device
> > drivers->IDE/ATAPI/MFM/RLL support menu.
> >
> > Jaroslav Sladek
> >
> >
> >
> > --
> > gentoo-laptop@g.o mailing list

--
gentoo-laptop@g.o mailing list


--
gentoo-laptop@g.o mailing list

References:
Re: Trying Gentoo linux on a new Asus M6 laptop
-- Henri Magnin
Navigation:
Lists: gentoo-laptop: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: Trying Gentoo linux on a new Asus M6 laptop
Next by thread:
Re: Trying Gentoo linux on a new Asus M6 laptop
Previous by date:
Re: Trying Gentoo linux on a new Asus M6 laptop
Next by date:
How to turn off cpu fan when I turn on my laptop?


Updated Jun 17, 2009

Summary: Archive of the gentoo-laptop mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.