Gentoo Archives: gentoo-lisp

From: Nick <gentoo-lisp@××××××.uk>
To: Ulrich Mueller <ulm@g.o>
Cc: gentoo-lisp@l.g.o
Subject: Re: [gentoo-lisp] Stumpwm emacs dependency
Date: Sun, 15 Nov 2009 15:15:21
Message-Id: 20091115151842.GA1836@slinky.tiscali.co.uk
In Reply to: Re: [gentoo-lisp] Stumpwm emacs dependency by Ulrich Mueller
Quoth Ulrich Mueller:
> >>>>> On Sun, 15 Nov 2009, Nick wrote: > > > However I see due to your build inheriting elisp it effectively > > depends on emacs. This seems like an odd dependency for a window > > manager, and I wonder if it's possible / reasonable to remove it? > > The ebuild should only depend on Emacs with USE=emacs, so it should > inherit elisp-common instead of elisp. See below for an (untested) > patch.
Thanks Ulrich! That has given me a sane dependency list now. However now the stumpwm build is breaking on compile (I don't know if this is introduced by this patch or not, I hadn't got this far before). I attach the build log and paludis --info. Thanks in advance, Nick -- Please GPG encrypt email to me if you are able. GPG : 0x04E4653F | 9732 D7C7 A441 D79E FDF0 94F6 1F48 5674 04E4 653F

Attachments

File name MIME type
installlog-stumpwm text/plain
paludisinfo-stumpwm text/plain

Replies

Subject Author
Re: [gentoo-lisp] Stumpwm emacs dependency Stelian Ionescu <sionescu@××××.org>