Gentoo Archives: gentoo-mips

From: "Stephen P. Becker" <geoman@g.o>
To: gentoo-mips@l.g.o
Subject: Re: [gentoo-mips] Emacs in X with toolkits?
Date: Thu, 24 Nov 2005 18:23:33
Message-Id: 43860506.8070108@gentoo.org
In Reply to: [gentoo-mips] Emacs in X with toolkits? by Karl-Johan 'Creideiki' Karlsson
> I've been trying to make Emacs work in X on my SGI Octane. KDE works, Emacs in > console mode works, and Emacs in X without toolkits also works, but if I > compile Emacs with either Xaw3d or Motif I get segfaults at startup. > > Looking around a bit, I see this problem reported as early as December 2001[1] > and as late as April 2005[2]. Other reports (with backtraces from GDB) are at > [3] and [4]. > > The Debian bug report[1] claims that this is due to a bug in a new version of > binutils and that it was fixed in January 2002. I have not found any details > about this binutils bug. > > Does anyone have any idea what's going on?
Short answer: no idea. We should have sufficiently recent versions of binutils. If you aren't already, try using binutils-2.16.1. I don't use emacs (and I don't really care to try), so I've totally neglected to bother testing it with X. Being brutally honest, emacs doesn't even have mips keywords, which tells me nobody has ever bothered to test, which probably means nobody in the history of gentoo/mips has ever cared about it until you came along. If what you say is true, we might even have to add -mips to the KEYWORDS, since there is no way in hell I'm going to use.mask X, Xaw3d, and motif just because they break emacs. If you find a fix, feel free to file a bug report attach the fix, and assign it to us. -Steve -- gentoo-mips@g.o mailing list

Replies

Subject Author
Re: [gentoo-mips] Emacs in X with toolkits? Karl-Johan 'Creideiki' Karlsson <creideiki+gentoo-mips@××××××××××.se>