Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-mips
Navigation:
Lists: gentoo-mips: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-mips@g.o
From: Matthias Bethke <matthias@...>
Subject: Qube2 can't load CoLo
Date: Wed, 16 May 2007 10:56:54 +0200
It's been quiet on this list for a while, eh? Here's a question for Qube
owners: 
I've been trying to get Gentoo running on my Qube 2, and while
things seem to work fine with minor glitches so far, I can't get the
CoLo chainloading to work. I've netbooted the box, CoLo loads fine from
NFS, loads my kernel, I've done all the installation of the base system,
and now I'm trying to get the Qube to boot on its own. What does work is
to netboot again so the CoLo image gets pulled from NFS, and then have
CoLo load and boot my kernel from disk by hand (it runs into problems
trying to start udev but I think I can get this fixed later, with
init=/bin/bash it's fine so far). It doesn't however want to load CoLo
from the boot partition:
| Cobalt Microserver Diagnostics - 'We serve it, you surf it'
| Built Tue May 25 15:58:41 PDT 1999
| 
|  1.LCD Test................................PASS
|  2.Controller Test.........................PASS
|  5.Bank 0:.................................64M
|  6.Bank 1:.................................64M
|  7.Bank 2:.................................64M
|  8.Bank 3:.................................64M
|  9.Serial Test.............................PASS
| 10.PCI Expansion Slot....................**Unknown Card**
| 12.IDE Test................................PASS
| 13.Ethernet Test...........................PASS
| 16.RTC Test................................PASS
| BOOTLOADER ramcode: selected partition /dev/hda1
| Decompressing done
| Executing bootloader kernel...
| Jump_to_Real_Kernel: disk error, trying BFD again
| BOOTLOADER ramcode: selected partition /dev/hdc1
| Decompressing - done
| Executing bootloader kernel...
| Jump_to_Real_Kernel: disk error, trying BFD again
| get_root_dev: nr_boot_failures 0x00000002 exceeds maxtries 0x00000002 for boot_index 0x00000000
| 
| 
|  *** halting ***

My hda1 looks like this:
| (none) etc # mount /boot
| (none) etc # ls -l /boot
| total 1152
| -rw-r--r-- 1 root root     353 Jan  1  2000 default.colo
| -rwxr-xr-x 1 root root 1098628 May 15  2007 kernel-2.6.17.14-mips.gz
| drwx------ 2 root root   12288 Jan  1  2000 lost+found
| -rw-r--r-- 1 root root   59614 Jan  1 01:07 vmlinux.gz
| lrwxrwxrwx 1 root root      24 May 15  2007 vmlinux.gz.working -> kernel-2.6.17.14-mips.gz

It is an ext2r0 partition and vmlinux.gz is the zipped colo-chain.elf.
I'm not sure about who writes what message in that console dump but it
seems to me that CoLo isn't even being loaded. Otherwise I should get a
menu on the console in case it couldn't find the kernel or something,
right?

cheers!
	Matthias
-- 
I prefer encrypted and signed messages. KeyID: FAC37665
Fingerprint: 8C16 3F0A A6FC DF0D 19B0  8DEF 48D9 1700 FAC3 7665
Attachment:
pgpZf3aiumnFL.pgp (PGP signature)
Replies:
Re: Qube2 can't load CoLo
-- Kumba
Navigation:
Lists: gentoo-mips: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: [gentoo-embedded] GNAP in Google SoC
Next by thread:
Re: Qube2 can't load CoLo
Previous by date:
Re: [gentoo-embedded] GNAP in Google SoC
Next by date:
Re: Qube2 can't load CoLo


Updated Jun 17, 2009

Summary: Archive of the gentoo-mips mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.