Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-mips
Navigation:
Lists: gentoo-mips: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-mips@g.o
From: "Karl-Johan 'Creideiki' Karlsson" <creideiki+gentoo-mips@...>
Subject: Emacs in X with toolkits?
Date: Thu, 24 Nov 2005 19:04:38 +0100
Hi,

I've been trying to make Emacs work in X on my SGI Octane. KDE works, Emacs in 
console mode works, and Emacs in X without toolkits also works, but if I 
compile Emacs with either Xaw3d or Motif I get segfaults at startup.

Looking around a bit, I see this problem reported as early as December 2001[1] 
and as late as April 2005[2]. Other reports (with backtraces from GDB) are at 
[3] and [4].

The Debian bug report[1] claims that this is due to a bug in a new version of 
binutils and that it was fixed in January 2002. I have not found any details 
about this binutils bug.

Does anyone have any idea what's going on?

1: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=126918
2: http://lists.debian.org/debian-mips/2005/04/msg00036.html
3: http://lists.debian.org/debian-mips/2003/03/msg00038.html
4: http://lists.debian.org/debian-mips/2002/01/msg00075.html

-- 
Karl-Johan "Creideiki" Karlsson
Attachment:
pgpmZbHGzm9rg.pgp (PGP signature)
Replies:
Re: Emacs in X with toolkits?
-- Stephen P. Becker
Navigation:
Lists: gentoo-mips: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Gentoo/MIPS SGI LiveCD RC5 release
Next by thread:
Re: Emacs in X with toolkits?
Previous by date:
Re: Gentoo/MIPS SGI LiveCD RC5 release
Next by date:
Re: Emacs in X with toolkits?


Updated Jun 17, 2009

Summary: Archive of the gentoo-mips mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.