Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-osx
Navigation:
Lists: gentoo-osx: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-osx@g.o
From: "m h" <sesquile@...>
Subject: [PREFIX] LDFLAGS confusing configure
Date: Mon, 10 Apr 2006 14:43:11 -0700
Hey Folks-

I'm running latest PREFIX (as of Friday) on Ubuntu.  I've run into an
issue that I hadn't run into previously on RHEL or FC3.  When trying
to emerge gzip, the configure fails complaining that it can't make c
executables:

checking for C compiler default output... configure: error: C compiler
cannot create executables
check `config.log' for details.

When running the configure by hand (using the provided options it
works).  The issue appears to be that config.log shows the following
being set:

ac_cv_env_LDFLAGS_set=set
ac_cv_env_LDFLAGS_value=' -L/opt/portage/Apr7/lib -lz'

These don't appear when configure is being run by hand.  An because
libz isn't found in that location (EPREFIX=/opt/portage/Apr7) it's
failing.

Any suggestions?

-matt

-- 
gentoo-osx@g.o mailing list


Navigation:
Lists: gentoo-osx: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
prefix - working packages
Next by thread:
[PREFIX] issue updating digest
Previous by date:
Re: [PREFIX] Ready to go on Ubuntu...
Next by date:
[PREFIX] issue updating digest


Updated Jun 17, 2009

Summary: Archive of the gentoo-osx mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.