List Archive: gentoo-perl
Note: Due to technical difficulties, the Archives are currently not up to date.
provides an alternative service for most mailing lists.c.f. bug 424647
Michael Cummings wrote:
> I'd like to propose adding two new vars to the perl-module.eclass. (all
> naming conventions completely open to change)
I think I know what made you think about it ;)
> echovar - if defined, used in src_prep for passing an answer to perl
> Makefile.Pl|perl Build.PL. Could save some overhead with ebuilds that
> need that extra input, letting us stick to the basic skeleton ebuild for
> even *more* perl-modules :)
I'm not sure I like the name, but I'd love to have this capability.
What about an extra var to be passed to Makefile.PL (not echo-ed), e.g.,
`perl Makefile.PL --whatever` and not `echo whatever | perl Makefile.PL`?
Just a thought...
> patchlist - array of patches to be applied in src_unpack. Just a
> thought, mostly along the same lines as above, cleaning up the skeletons
> and putting more work in the eclass.
You have my vote for it.
email@example.com mailing list