Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-perl
Navigation:
Lists: gentoo-perl: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-perl@g.o
From: Kent Fredric <kentfredric@...>
Subject: Re: DBD-mysql should not depend on dev-db/mysql
Date: Thu, 2 Jul 2009 06:21:34 +1200
<br><br><div class="gmail_quote">On Thu, Jul 2, 2009 at 2:54 AM, Zhang Jun <span dir="ltr">&lt;<a href="mailto:gb2313@...">gb2313@...</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
DBD::mysql is just need some mysql library and header files,<br>
mysqld should not be needed.<br>
<br>
maybe the reason is gentoo does not like other pre-compiled distro,<br>
and compiling the header/lib need compile mysqld ?<br>
<br>
# emerge -pvt DBD-mysql<br>
<br>
These are the packages that would be merged, in reverse order:<br>
<br>
Calculating dependencies... done!<br>
[ebuild  N    ] dev-perl/DBD-mysql-4.00.5  120 kB<br>
[ebuild  N    ]  virtual/mysql-5.0  0 kB<br>
[ebuild  N    ]   dev-db/mysql-5.0.70-r1  USE=&quot;berkdb perl ssl<br>
-big-tables -cluster -debug -embedded -extraengine -latin1<br>
-max-idx-128 -minimal (-selinux) -static&quot; 28,028 kB<br>
[ebuild  N    ]    dev-db/mysql-init-scripts-1.2  0 kB<br>
[ebuild  N    ]    sys-apps/ed-1.0  67 kB<br>
<br>
</blockquote></div><br><br clear="all">  &lt;flag name=&#39;minimal&#39;&gt;Install client programs only, no server&lt;/flag&gt;<br><br>-- <br>Kent <br><br>perl -e  &quot;print substr( \&quot;edrgmaM  SPA NOcomil.ic\\@tfrken\&quot;, \$_ * 3, 3 ) for ( 9,8,0,7,1,6,5,4,3,2 );<br>
<br><a href="http://kent-fredric.fox.geek.nz">http://kent-fredric.fox.geek.nz</a><br>
References:
DBD-mysql should not depend on dev-db/mysql
-- Zhang Jun
Navigation:
Lists: gentoo-perl: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: DBD-mysql should not depend on dev-db/mysql
Next by thread:
how to use g-cpan ?
Previous by date:
Re: DBD-mysql should not depend on dev-db/mysql
Next by date:
Re: DBD-mysql should not depend on dev-db/mysql


Updated Sep 25, 2011

Summary: Archive of the gentoo-perl mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.