Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-perl
Navigation:
Lists: gentoo-perl: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-perl@g.o
From: Steven Lembark <lembark@...>
Subject: Re: how it goes with perl 5.10
Date: Sat, 20 Dec 2008 14:47:48 -0500
> One problem is portage is removing old perl 
> 5.8 modules when emerging new ones. I don't 
> think this is needed, as long as @INC is correct.

Should be built properly via perl's normal make cycle.

Intention is to leave the old library in place to avoid
the user having to-rebuild everything from scratch every
time.

> Changing /usr/bin/perl to point to the right 
> binary should be all that is needed, IIRC to 
> get back 5.8... Anyway, (from what I know) an 
> eselect perl thingy *should* be dead simple to 
> make this easy for the user.

Yup: backing off the executable will run a perl with
the older @INC higher up in the versions.

-- 
Steven Lembark                                            85-09 90th St.
Workhorse Computing                                 Woodhaven, NY, 11421
lembark@...                                      +1 888 359 3508


References:
how it goes with perl 5.10
-- perl
Navigation:
Lists: gentoo-perl: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
how it goes with perl 5.10
Next by thread:
modules availability
Previous by date:
modules availability
Next by date:
Re: modules availability


Updated Jun 17, 2009

Summary: Archive of the gentoo-perl mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.