Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-perl
Navigation:
Lists: gentoo-perl: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-perl@g.o
From: Adam Prime <adam.prime@...>
Subject: Re: perl 5.10
Date: Fri, 03 Apr 2009 10:01:26 -0400
Kent Fredric wrote:
> 
> 
> I'm confused, how does installing catalyst have anything on Perl 5.10 
> dependencies.
> 
> They may all be in the same overlay, but dependency tracking still works 
> as normal.
> 
> I don't myself *see* anything that would cause installation of Perl 5.10 
> to *require* the installation of Catalyst . 
> 
> If it is telling you that you need to install catalyst, then you'll 
> probably want to reply with a paste of the dependency tree how your 
> machine resolves it, because that's rather unusual.

Perhaps this has more to do with my lack of understanding of how 
overlays work more than anything else.  Based on what you've said I 
should just be able to unmask perl 5.10, and emerge perl and that should 
work just install base perl, and perhaps all the modules i had installed 
for 5.8.8 (that exist in portage anyway)?

I was looking at instructions in a wiki somewhere, which i of course 
can't find now. (not the one linked from the thread about catalyst in 
the forums).  For some reason that article made me think using the 
overlay was an all or nothing deal.

Thanks,

Adam


Replies:
Re: perl 5.10
-- Kent Fredric
References:
perl 5.10
-- Adam Prime
Re: perl 5.10
-- Kent Fredric
Navigation:
Lists: gentoo-perl: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: perl 5.10
Next by thread:
Re: perl 5.10
Previous by date:
Re: perl 5.10
Next by date:
Re: perl 5.10


Updated Jun 17, 2009

Summary: Archive of the gentoo-perl mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.