Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-perl
Navigation:
Lists: gentoo-perl: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-perl@g.o
From: Michael Cummings <mcummings@g.o>
Subject: Re: Catalyst installation using g-cpan
Date: Sun, 3 Jul 2005 13:45:21 -0400
On Sunday 03 July 2005 10:50, Michele Beltrame wrote:
> Is this a problem in how Catalyst "announces" the missing prerequisites?
>

I suspect it is (most of those should be present as ebuilds already in portage 
at that). This all goes to one of the 2 underlying problems I have with how 
g-cpan currently detects dependancies - it doesn't note deps that are already 
installed, and it doesn't note versions of the deps. Instead it relies on 
cpan to notice the missing deps - but I'm not sure how this works if the 
module in question is using extutils::autoconfig and therefore sidestepping 
the cpan.pm detection (which I suspect happened to you in Catalyst).


Oh, for time and time and time to work on this :)


-- 
-----o()o---------------------------------------------
Michael Cummings   |    #gentoo-dev, #gentoo-perl
Gentoo Perl Dev    |    on irc.freenode.net 
-----o()o---------------------------------------------
Attachment:
pgpHCgvV4k56A.pgp (PGP signature)
Replies:
Re: Catalyst installation using g-cpan
-- Antoine Raillon
References:
Catalyst installation using g-cpan
-- Michele Beltrame
Navigation:
Lists: gentoo-perl: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Catalyst installation using g-cpan
Next by thread:
Re: Catalyst installation using g-cpan
Previous by date:
Catalyst installation using g-cpan
Next by date:
Re: Catalyst installation using g-cpan


Updated Jun 17, 2009

Summary: Archive of the gentoo-perl mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.