Gentoo Archives: gentoo-pms

From: Zac Medico <zmedico@g.o>
To: gentoo-pms@l.g.o
Subject: Re: [gentoo-pms] EAPI 5 (Was: Re: [gentoo-dev] Re: Making user patches globally available)
Date: Fri, 27 Apr 2012 23:45:55
Message-Id: 4F9B2FA4.7000409@gentoo.org
In Reply to: [gentoo-pms] EAPI 5 (Was: Re: [gentoo-dev] Re: Making user patches globally available) by Ciaran McCreesh
On 04/27/2012 01:12 PM, Ciaran McCreesh wrote:
> On Fri, 27 Apr 2012 21:58:24 +0200 > Michał Górny <mgorny@g.o> wrote: >> Of course, if we take the 'quick EAPI 5 route', it won't include >> anything useful. In the meantime, do we have a complete list of >> candidates for EAPI 5? > > Let's continue this on the PMS list. > > * user patches > > * EAPI parsing > > * the things that were left out of 4: > > + slot operator deps > > + profile IUSE > > * No -j1 for src_test > > * Remove deprecated stuff > > * Zero or one REQUIRED_USE operator > > These might be cheap now? > > * New bash version > > * Get a versionator replacement into the PM >
* has_version and best_version argument for cross compiling $ROOT See https://bugs.gentoo.org/show_bug.cgi?id=401239 -- Thanks, Zac