Gentoo Archives: gentoo-pms

From: Zac Medico <zmedico@g.o>
To: gentoo-pms@l.g.o
Subject: Re: [gentoo-pms] Re: EAPI 5
Date: Sun, 13 May 2012 20:57:18
Message-Id: 4FB0201F.9050901@gentoo.org
In Reply to: [gentoo-pms] Re: EAPI 5 by "Andreas K. Huettel"
On 04/30/2012 03:14 PM, Andreas K. Huettel wrote:
> Am Freitag 27 April 2012, 22:12:27 schrieb Ciaran McCreesh: >> On Fri, 27 Apr 2012 21:58:24 +0200 >> >> Michał Górny <mgorny@g.o> wrote: >>> Of course, if we take the 'quick EAPI 5 route', it won't include >>> anything useful. In the meantime, do we have a complete list of >>> candidates for EAPI 5? >> >> Let's continue this on the PMS list. >> > [...] > > Pretty please, > > * package.use.stable.mask and package.use.stable.force support, as discussed > on gentoo-dev (there and on IRC feedback was pretty much positive) > > http://archives.gentoo.org/gentoo-dev/msg_6c492ae43ad7c70cef6aa8ac34911adf.xml
We'd probably also want to add a use.stable file, in order to control default USE settings for stable users. This could come in handy for creating default PYTHON_TARGETS settings that correspond to the users's latest visible slots of python, as discussed here: https://bugs.gentoo.org/show_bug.cgi?id=415575#c5 -- Thanks, Zac