Gentoo Archives: gentoo-pms

From: "Petteri Räty" <betelgeuse@g.o>
To: gentoo-pms@l.g.o
Subject: [gentoo-pms] Clarification of has_version cat/pkg[use=] behavior for EAPI 3 or 4
Date: Sat, 12 Sep 2009 17:42:15
Message-Id: 4AABDD67.606@gentoo.org
Currently Portage does not work with has_version cat/pkg[use=]. I filed 
a bug about this:
https://bugs.gentoo.org/show_bug.cgi?id=284715

Portage current behavior:
17:38 <@zmedico> Betelgeuse: quick test seems to show always true if 
it's in IUSE

I see a couple course of possible actions:
1. Current PMS already implies this behavior and Portage is buggy. Let's 
document this explicitly for EAPI 3 and have Portage fixed so using EAPI 
3 makes sure this syntax works.
2. PMS currently does not specify this properly and as such this would 
belong to EAPI 4.
3. Suggestions welcome.

Regards,
Petteri

Replies