Gentoo Archives: gentoo-pms

From: "Tiziano Müller" <dev-zero@g.o>
To: gentoo-pms@l.g.o
Subject: Re: [gentoo-pms] EAPI 5 (Was: Re: [gentoo-dev] Re: Making user patches globally available)
Date: Sat, 28 Apr 2012 17:11:23
Message-Id: 1335633063.4823.48.camel@storm
In Reply to: [gentoo-pms] EAPI 5 (Was: Re: [gentoo-dev] Re: Making user patches globally available) by Ciaran McCreesh
Could we also get an interface to disk- and memory-space requirements?

Something like:
  
  EREQUIRE_DISK="2G"
  EREQUIRE_MEMORY="1G"

which gets checked in pre_pkg_setup?

Am Freitag, den 27.04.2012, 21:12 +0100 schrieb Ciaran McCreesh:
> On Fri, 27 Apr 2012 21:58:24 +0200 > Michał Górny <mgorny@g.o> wrote: > > Of course, if we take the 'quick EAPI 5 route', it won't include > > anything useful. In the meantime, do we have a complete list of > > candidates for EAPI 5? > > Let's continue this on the PMS list. > > * user patches > > * EAPI parsing > > * the things that were left out of 4: > > + slot operator deps > > + profile IUSE > > * No -j1 for src_test > > * Remove deprecated stuff > > * Zero or one REQUIRED_USE operator > > These might be cheap now? > > * New bash version > > * Get a versionator replacement into the PM >

Attachments

File name MIME type
smime.p7s application/x-pkcs7-signature

Replies

Subject Author
Re: [gentoo-pms] EAPI 5 (Was: Re: [gentoo-dev] Re: Making user patches globally available) Ciaran McCreesh <ciaran.mccreesh@××××××××××.com>