Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-pms
Navigation:
Lists: gentoo-pms: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-pms@g.o
From: Petteri R├Ąty <betelgeuse@g.o>
Subject: Clarification of has_version cat/pkg[use=] behavior for EAPI 3 or 4
Date: Sat, 12 Sep 2009 20:41:59 +0300
Currently Portage does not work with has_version cat/pkg[use=]. I filed 
a bug about this:
https://bugs.gentoo.org/show_bug.cgi?id=284715

Portage current behavior:
17:38 <@zmedico> Betelgeuse: quick test seems to show always true if 
it's in IUSE

I see a couple course of possible actions:
1. Current PMS already implies this behavior and Portage is buggy. Let's 
document this explicitly for EAPI 3 and have Portage fixed so using EAPI 
3 makes sure this syntax works.
2. PMS currently does not specify this properly and as such this would 
belong to EAPI 4.
3. Suggestions welcome.

Regards,
Petteri


Replies:
Re: Clarification of has_version cat/pkg[use=] behavior for EAPI 3 or 4
-- Christian Faulhammer
Re: Clarification of has_version cat/pkg[use=] behavior for EAPI 3 or 4
-- Ciaran McCreesh
Navigation:
Lists: gentoo-pms: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
use.defaults
Next by thread:
Re: Clarification of has_version cat/pkg[use=] behavior for EAPI 3 or 4
Previous by date:
Re: use.defaults
Next by date:
Re: Clarification of has_version cat/pkg[use=] behavior for EAPI 3 or 4


Updated Jul 18, 2012

Summary: Archive of the gentoo-pms mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.