Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-pms
Navigation:
Lists: gentoo-pms: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-pms@g.o
From: "Andreas K. Huettel" <dilfridge@g.o>
Subject: Re: package.use.stable.mask and package.use.stable.force
Date: Sun, 1 Jul 2012 21:22:48 +0200
Am Samstag 23 Juni 2012, 22:17:51 schrieb Ciaran McCreesh:
> On Sat, 23 Jun 2012 22:09:31 +0200
> 
> "Andreas K. Huettel" <dilfridge@g.o> wrote:
> > It is certainly possible refine this more. Allowing only EAPI=5
> > ebuilds in package.use.stable.*, and have the files only take effect
> > there, comes to my mind. However I doubt if these restrictions are
> > really necessary and if a EAPI dependence at this place in the
> > profile makes actually sense.
> 
> The way we usually word such things is to have a table of EAPIs where
> support is required if the package mangler accepts indicated EAPIs. Then
> it's an error for ebuilds to rely upon support if they don't use one of
> those EAPIs. This gets you out of the profile EAPI requirement.

OK, additional patch (on top of the previous one) is included. It states that 
atoms inside package.use.stable.mask etc *must* resolve only to EAPI 5 
ebuilds.

I'm not fully convinced yet that this restriction is really necessary, but 
it's imho a compromise. 

Cheers, 
Andreas

-- 

Andreas K. Huettel
Gentoo Linux developer 
dilfridge@g.o
http://www.akhuettel.de/

Attachment:
0002-Pin-stable-masking-to-EAPI-5.patch (Text Data)
Attachment:
signature.asc (This is a digitally signed message part.)
References:
package.use.stable.mask and package.use.stable.force
-- Andreas K. Huettel
Re: package.use.stable.mask and package.use.stable.force
-- Ciaran McCreesh
Navigation:
Lists: gentoo-pms: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: package.use.stable.mask and package.use.stable.force
Previous by date:
Re: package.use.stable.mask and package.use.stable.force


Updated Jul 18, 2012

Summary: Archive of the gentoo-pms mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.