Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-ppc-dev
Navigation:
Lists: gentoo-ppc-dev: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-security@g.o
From: Daniel Ahlberg <aliz@g.o>
Subject: GLSA: OpenAFS
Date: Sat Aug 3 18:40:13 2002
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - --------------------------------------------------------------------
GENTOO LINUX SECURITY ANNOUNCEMENT
- - --------------------------------------------------------------------

PACKAGE        :openafs
SUMMARY        :remote root
DATE           :2002-08-03 23:26 UTC

- - --------------------------------------------------------------------

OVERVIEW

A remote user may be able to gain root access to an OpenAFS database
server or fileserver host.  In addition, certain administrative clients
may be attacked if they make requests to a rogue server.

DETAIL

There is an integer overflow bug in the SUNRPC-derived RPC library
used by OpenAFS that could be exploited to crash certain OpenAFS
servers (volserver, vlserver, ptserver, buserver) or to obtain
unauthorized root access to a host running one of these processes.

In addition, it is possible for a rogue server to attack certain
administrative clients (vos, pts, backup, butc, rxstat), but only
if certain RPC requests are made to the rogue server.

The OpenAFS fileserver and cache manager (client) are not vulnerable
to these attacks.  No exploits are presently known to be available
for this vulnerability.

The full advisory may be found here:
http://www.openafs.org/pages/security/OPENAFS-SA-2002-001.txt

SOLUTION

This security issue was fixed in ebuild version 1.2.5-r1 uploaded to 
portage on Fri Aug 2 22:47:20 2002 UTC. The OpenAFS team has released
OpenAFS 1.2.6 to fix this security issue.

It is recommended that all Gentoo Linux users who has OpenAFS installed
update their systems as follows.

emerge rsync
emerge openafs
emerge clean

- - --------------------------------------------------------------------
Daniel Ahlberg
aliz@g.o
- - --------------------------------------------------------------------
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.7 (GNU/Linux)

iD8DBQE9TGmlfT7nyhUpoZMRAsL3AKC+ZvjuRFBXxSDCvwzeFtRjihclawCghcwF
EppTLAfmlWfN5P5pcBVDedk=
=dEvV
-----END PGP SIGNATURE-----


Navigation:
Lists: gentoo-ppc-dev: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
GLSA: krb5
Next by thread:
PPC 1.4_beta test release available
Previous by date:
GLSA: krb5
Next by date:
PPC 1.4_beta test release available


Updated Jun 17, 2009

Summary: Archive of the gentoo-ppc-dev mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.