Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-ppc-user
Navigation:
Lists: gentoo-ppc-user: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-ppc-user@g.o
From: Joseph Jezak <josejx@g.o>
Subject: Re: Booting Gentoo 2006.1 on an iMac
Date: Wed, 13 Sep 2006 07:54:08 -0400
Charles Trois wrote:
> Joseph Jezak a écrit :
>>
>> Charles Trois wrote:
>>> What happens is that, on the final reboot, I see 10 or 15 lines of text
>>> (is that the Open Firmware part?) that disappear immediately. Then there
>>> is nothing, and I have to cut the power to go on.
>>
>> This sounds an awful lot like you're missing the Framebuffer device
>> driver.  Which iMac do you have exactly?  Perhaps try the
>> Framebuffer/X setup suggested in the PPC FAQ as described here:
>> http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml#xorg
>>
>> - -Joe
> Many thanks to all who have replied!
> The problem was indeed one of framebuffer.
> 
> My machine is a G4 iMac with LCD.
> The video card is a NVIDIA GeForce2 MX.
> I had to add support for nvidia fb device in the kernel (the handbook
> states that only the OF device should be used in the case of nvidia, but
>  I obviously misunderstood this).
> 
> This solved my first problem. I got into a further one about udev, which
>  I was able to fix (support for tmpfs was missing).
> 
> And now it is a clock problem. The error message (copied by hand) reads:
> 
> Cannot access the hardware clock... try the --debug option.
> 
> hwclock --debug gives this:
> 
> hwclock: Open of /dev/rtc failed, errno=2: no such file or directory
> No usable clock interface found
> 
> This is strange, as /dev/rtc exists. On the kernel side there is "yes"
> to "RTCclass", "sysfs", "proc" and "dev". The RTC to read is "rtc0".
> 
> Any suggestions?
> 
> By the way, enablecdboot did not work because I had written
> "enable cdboot". My mistake.
> 
> Charles

To fix the clock problem, make sure that you have the Generic RTC
emulation and the Extended RTC Emulation enabled.

As for the Framebuffer issue, it seems to change every kernel as to
which Framebuffer driver (OF, rivafb, or nvidiafb) is working. :p
Sorry for the confusion.

-Joe
-- 
gentoo-ppc-user@g.o mailing list


Replies:
Re: Booting Gentoo 2006.1 on an iMac
-- Charles Trois
References:
Booting Gentoo 2006.1 on an iMac
-- Charles Trois
Re: Booting Gentoo 2006.1 on an iMac
-- Joseph Jezak
Re: Booting Gentoo 2006.1 on an iMac
-- Charles Trois
Navigation:
Lists: gentoo-ppc-user: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: Booting Gentoo 2006.1 on an iMac
Next by thread:
Re: Booting Gentoo 2006.1 on an iMac
Previous by date:
Re: Booting Gentoo 2006.1 on an iMac
Next by date:
Re: Booting Gentoo 2006.1 on an iMac


Updated Jun 17, 2009

Summary: Archive of the gentoo-ppc-user mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.