Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-ppc-user
Navigation:
Lists: gentoo-ppc-user: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentooppc-user@g.o
From: linux-dev <linux-dev@...>
Subject: ybin/yaboot problems
Date: Sat Apr 27 13:27:01 2002
...been away from the ppc for a while, now i'm trying to,
once again, get gentoo running.

the new .iso works wonderfully.  everything went well.

but after modifying my /etc/yaboot.conf file, which looks ok,
i can't seem to run ybin successfully.  can anyone interpret
these messages?  do you know why i'm getting them?

# ybin -v --debug
ybin: Finding OpenFirmware device path to `/dev/hda9'...
ybin: DEBUG: ofboot set to `hd:9'
ybin: Finding OpenFirmware device path to `/dev/hda10'...
ybin: DEBUG: macos set to `hd:10' from `/dev/hda10'
ybin: DEBUG: OS=4
ybin: DEBUG: /bin/sh /usr/lib/yaboot/ofboot 4 bootyaboot 5  0 yaboot GNU l hd:9 ,\\yaboot  macos MacOS m hd:10 ,\\:tbxi   cd CDROM c cd: ,\\:tbxi  of OpenFirmware o quit now
ybin: DEBUG: set magicboot to /tmp/ofboot.n8gbdG
ybin: Installing first stage bootstrap /usr/lib/yaboot/ofboot onto /dev/hda9...
hcopy: "/tmp/ofboot.n8gbdG": read-only file system
ybin: An error occured while writing to /dev/hda9


--------------------------------------------------------------------------------------------
here's my yaboot.conf file (changing things here doesn't seem to affect the error much):

boot=/dev/hda9
default=linuxppc
device=hd:
partition=12
delay=5
defaultos=linux
timeout=40
install=/usr/lib/yaboot/yaboot
magicboot=/usr/lib/yaboot/ofboot

image=/boot/vmlinux
      root=/dev/hda12
      label=linuxppc
      read-only

macos=/dev/hda10
enablecdboot
enableofboot

---------------------------------------------------------------------------------------------
file system layout:

# mac-fdisk -l

[8 Apple Partitions /dev/hda1 - /dev/hda8]

     /dev/hda9   Apple_Bootstrap untitled      ...      1 M NewWorld bootblock
     /dev/hda10        Apple_HFS untitled 2    ...   10.4 G HFS

[the following partitions now use the xfs filesystem]

     /dev/hda11  Apple_UNIX_SVR2 swap          ...    192 M Linux swap
     /dev/hda12  Apple_UNIX_SVR2 untitled      ...    2.8 G Linux native
     /dev/hda13  Apple_UNIX_SVR2 untitled      ...    3.8 G Linux native
     /dev/hda14  Apple_UNIX_SVR2 untitled      ...    1.5 G Linux native
     /dev/hda15  Apple_UNIX_SVR2 untitled      ...    400 M Linux native
     /dev/hda16  Apple_UNIX_SVR2 untitled      ...    8.9 G Linux native





any ideas/suggestions/help/comments would be appreciated !

/r.




Replies:
Re: ybin/yaboot problems
-- linux-dev
Navigation:
Lists: gentoo-ppc-user: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
mac-on-linux
Next by thread:
Re: ybin/yaboot problems
Previous by date:
mac-on-linux
Next by date:
Re: ybin/yaboot problems


Updated Jun 17, 2009

Summary: Archive of the gentoo-ppc-user mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.