Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-ppc-user
Navigation:
Lists: gentoo-ppc-user: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-ppc-user@g.o
From: Johannes Geiss <johannes.geiss@...>
Subject: Pegasos II + Radeon 9000: No DRI and wrong colours for OpenGL
Date: Wed, 10 Jun 2009 14:33:34 +0200
Hi there,

I updated my xorg-server to the latest version 1.5.3-r6 and now my X11
performance for OpenGL (Mesa 7.3-r1) is bad and has wrong colours (eg.
glxgears).

grep -e "\[drm\]" Xorg.0.log

(II) [drm] DRM interface version 1.3
(II) [drm] DRM open master succeeded.
(II) RADEON(0): [drm] Using the DRM lock SAREA also for drawables.
(II) RADEON(0): [drm] framebuffer handle = 0xc0000000
(II) RADEON(0): [drm] added 1 reserved context for kernel
(II) RADEON(0): [drm] installed DRM signal handler
(II) RADEON(0): [drm] register handle = 0x29000000
(II) RADEON(0): [drm] Added 32 65536 byte vertex/indirect buffers
(II) RADEON(0): [drm] Mapped 32 vertex/indirect buffers
(II) RADEON(0): [drm] failure adding irq handler, there is a device
already using that irq
[drm] falling back to irq-free operation
(II) RADEON(0): [drm] Initialized kernel GART heap manager, 5111808
(II) RADEON(0): [drm] removed 1 reserved context for kernel
(II) RADEON(0): [drm] unmapping 8192 bytes of SAREA 0xf1076000 at
0x48024000
(II) RADEON(0): [drm] Closed DRM master.

grep -e "^(EE)" Xorg.0.log

(EE) Failed to load module "fbdev" (module does not exist, 0)
(EE) Failed to load module "vesa" (module does not exist, 0)
(EE) AIGLX error: drmOpenOnce failed (Operation not permitted)
(EE) AIGLX: reverting to software rendering
(EE) PreInit returned NULL for "MOSIC      SPEED-LINK Competition Pro"
(EE) config/hal: NewInputDeviceRequest failed
(EE) PreInit returned NULL for "MOSIC      USB 2A4K  GamePad"
(EE) config/hal: NewInputDeviceRequest failed

It seems to be a problem with AIGLX (drmOpenOnce failed). But I have

Section "DRI"
        Mode 0666
EndSection

and

Option  "BusType"       "PCI"

in my xorg.conf

Does anybody have a suggestion?

Thanks for any help
Johannes
-- 

------//--------------------------------------------------------------
     //    Johannes R. Geiss       Zaurus, Pegasos, Amiga and C64 user
 \\ //                   PGP at http://home.arcor.de/jgeiss/pgpkey.txt
--\X/-----------------------------------------------------------------
Attachment:
signature.asc (This is a digitally signed message part)
Replies:
Re: Pegasos II + Radeon 9000: No DRI and wrong colours for OpenGL
-- Johannes Geiss
Navigation:
Lists: gentoo-ppc-user: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
X on an older PPC-based Mac Mini?
Next by thread:
Re: Pegasos II + Radeon 9000: No DRI and wrong colours for OpenGL
Previous by date:
Re: What new profile for an old Mac Mini as a MythTV backend server?
Next by date:
Re: Pegasos II + Radeon 9000: No DRI and wrong colours for OpenGL


Updated Jun 19, 2009

Summary: Archive of the gentoo-ppc-user mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.