Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-ppc-user
Navigation:
Lists: gentoo-ppc-user: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-ppc-user@g.o
From: Charles Trois <charles.trois@...>
Subject: Re: Compile error on IDE Power Mac driver
Date: Thu, 01 Dec 2005 15:45:01 +0100
Draeven a écrit :
>  
> Charles Trois wrote:
> Charles,
> 
> Did you do a "rc-update add net.eth0 default" so that the interface is 
> brought up at boot?
> 
> You may also want to take a look at this section of the Gentoo Handbook:
> 
> http://www.gentoo.org/doc/en/handbook/handbook-ppc.xml?part=4
> 
I am still working hard at this; I even have burnt a new CD and
reinstalled from it, but there is nothing doing. To state my problem
again, it occurs on an G4 iMac with the Gentoo universal
ppc-install-2005.1 disc. At the end of the boot process, just before the
login, I get this:

==========================================================================

  * Starting syslog-ng ...

[ ok ] * Starting gpm ...

[ ok ] * Starting eth0
  *   Bringing up eth0
  *     Configuration not set for eth0 - assuming dhcp
  *     dhcp
  *       Running dhcpcd ...

[ !! ] * Starting vixie-cron ...

[ ok ] * Starting local ...

[ ok ] * ERROR:  Problem starting needed services.
  *         "netmount" was not started.

==========================================================================

And the corresponding bit in /var/log/messsages is:

==========================================================================

Dec  1 11:00:55 sirrah rc-scripts: Configuration not set for eth0 -
assuming dhcp
Dec  1 11:01:55 sirrah dhcpcd[4718]: timed out waiting for a valid DHCP
server response
Dec  1 11:01:55 sirrah cron[5378]: (CRON) STARTUP (V5.0)
Dec  1 11:01:56 sirrah rc-scripts: ERROR:  Problem starting needed services.
Dec  1 11:01:56 sirrah rc-scripts:         "netmount" was not started.
Dec  1 11:02:50 sirrah login(pam_unix)[5457]: session opened for user
root by (uid=0)

==========================================================================

The cause of the trouble seems to be pointed out by the line
"dhcpcd[4718]: timed out waiting for a valid DHCP server response" (and
there is indeed quite a delay at the stage "Running dhcpcd").

But now what can I do to get this "valid DHCP server response"? There
seems to be nothing about dhcp in the .config file: what then? does it 
suppose that I am already connected to the Net?

Charles


-- 
gentoo-ppc-user@g.o mailing list


Replies:
Re: Compile error on IDE Power Mac driver
-- Joseph Jezak
Re: Compile error on IDE Power Mac driver
-- Draeven
References:
Compile error on IDE Power Mac driver
-- Charles Trois
Re: Compile error on IDE Power Mac driver
-- Michael Hanselmann
Re: Compile error on IDE Power Mac driver
-- Charles Trois
Re: Compile error on IDE Power Mac driver
-- Joseph Jezak
Re: Compile error on IDE Power Mac driver
-- Charles Trois
Re: Compile error on IDE Power Mac driver
-- Matti Bickel
Re: Compile error on IDE Power Mac driver
-- Charles Trois
Re: Compile error on IDE Power Mac driver
-- Draeven
Re: Compile error on IDE Power Mac driver
-- Charles Trois
Re: Compile error on IDE Power Mac driver
-- Draeven
Navigation:
Lists: gentoo-ppc-user: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: Compile error on IDE Power Mac driver
Next by thread:
Re: Compile error on IDE Power Mac driver
Previous by date:
unsubscribe
Next by date:
Re: Compile error on IDE Power Mac driver


Updated Jun 17, 2009

Summary: Archive of the gentoo-ppc-user mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.