Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-python
Navigation:
Lists: gentoo-python: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-python@g.o
From: Johan Bergström <bugs@...>
Subject: Re: Leaving 2.4 behind
Date: Sat, 3 Dec 2011 18:37:57 +0100
On 12/02/2011 09:05 AM, Dirkjan Ochtman wrote:
> Hi there,
> 
> I feel it's about time to leave 2.4 behind. We've seen an uptick in
> packages that don't support it anymore (making life harder for us if
> we're trying to test for it), and at least some of our devs don't have
> it installed anymore. In the wider ecosystem, as well, it seems like
> other parties are also ending support for 2.4.
I've seen this trend too. Stuff like with statements and conditional expressions is making 2.5 take 2.4's place as lowest req. 
> 
> Anyone opposed?
Unless there are packages that explicitly need 2.4 I'm all for removing it. There's no point in having an older version around since it only adds maintenance when bumping packages.

(Additionally, should there be a list of packages depending on 2.4 and nothing else - we should evaluate and act upon these).


Thanks,
Johan



References:
Leaving 2.4 behind
-- Dirkjan Ochtman
Re: Leaving 2.4 behind
-- Mike Gilbert
Navigation:
Lists: gentoo-python: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: Leaving 2.4 behind
Next by thread:
Re: Leaving 2.4 behind
Previous by date:
Re: Leaving 2.4 behind
Next by date:
Re: Leaving 2.4 behind


Updated Jun 29, 2012

Summary: Archive of the gentoo-python mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.