Gentoo Archives: gentoo-releng

From: Brad House <brad_mssw@g.o>
To: Martin Schlemmer <azarah@g.o>
Cc: gentoo-releng@l.g.o
Subject: Re: [gentoo-releng] x86-livecd - bugs and suggestions
Date: Sun, 25 Jan 2004 08:20:37
Message-Id: 64535.68.105.173.45.1075018834.squirrel@mail.mainstreetsoftworks.com
In Reply to: Re: [gentoo-releng] x86-livecd - bugs and suggestions by Martin Schlemmer
Attached is a patch based of yours that is tested and works fine.
This applies against your -r5 rc-scripts

I've also updated my  -r4  ebuild to pull a fully patched version
that includes these patches.

The CD reboots just fine with root mounted on a loop device. Also,
I took care of quite a few other little errors (LVM/RAID).

A few deps you'll need for livecds now:
baselayout-1.8.6.12-r4 (as of this evening, or a patched version
                        that may be released later by Azarah)
livecd-tools-1.0.0_beta2 (autoconfig and net-setup scripts)
genkernel-3.0.1_beta7

Works well, though we seem to be getting an error when it tries to start
hotplug from within the autoconfig script about needing to run
/sbin/depscan.sh.  I made it run /sbin/depscan during the livecd creation
to try to get rid of this error, but it did not seem to help, so I'm not
sure under what circumstances this can occur, but it does seem that
hotplug does start, and works properly, so I'm somewhat at a loss, other
than that, the livecd seems to be 100% in sync with the previous livecds
at this point.

(My testing was on AMD64 if anyone is curious)

-Brad

Attachments

File name MIME type
rc-scripts-livecd.patch application/octet-stream

Replies

Subject Author
Re: [gentoo-releng] x86-livecd - bugs and suggestions Martin Schlemmer <azarah@g.o>
Re: [gentoo-releng] x86-livecd - bugs and suggestions Martin Schlemmer <azarah@g.o>
Re: [gentoo-releng] x86-livecd - bugs and suggestions Martin Schlemmer <azarah@g.o>