Gentoo Archives: gentoo-science

From: Steven Trogdon <strogdon@×××××.edu>
To: gentoo-science@l.g.o
Subject: Re: [gentoo-science] sci-mathematics/sage-4.7.1 and numpy version
Date: Wed, 24 Aug 2011 15:48:43
Message-Id: 20110824104700.47e095f2@pavilion64.home.lan
In Reply to: [gentoo-science] sci-mathematics/sage-4.7.1 and numpy version by rose@rz.uni-potsdam.de
On Wed, 24 Aug 2011 12:03:19 +0200
rose@××××××××××××××.de wrote:

> Hi, > > I just installed more or less succesful sage. During the installation > numpy was downgraded from numpy-1.6.1 to numpy-1.5.1. > Now every 'emerge -uvDN world' complaines about; > > WARNING: One or more updates have been skipped due to a dependency conflict: > > dev-python/numpy:0 > > (dev-python/numpy-1.6.1::gentoo, ebuild scheduled for merge) conflicts with > ~dev-python/numpy-1.5.1 required by > (sci-mathematics/sage-4.7.1::sage-on-gentoo, installed) > > dev-python/pexpect:0 > > (dev-python/pexpect-2.4-r1::sage-on-gentoo, ebuild scheduled for > merge) conflicts with > ~dev-python/pexpect-2.0 required by > (sci-mathematics/sage-4.7.1::sage-on-gentoo, installed) > > If I try to install couchdb, numpy-1.6.1 will be installed again: > > root@caiman:/root(4)# emerge -pvuDN couchdb > > These are the packages that would be merged, in order: > > Calculating dependencies... done! > [ebuild N ] dev-lang/erlang-14.2.3 USE="doc emacs java odbc smp > ssl tk wxwidgets -halfword -hipe -kpoll -sctp" 98,075 kB > [ebuild N ] dev-db/couchdb-1.1.0 USE="-test" 1,063 kB > [ebuild U ] dev-python/numpy-1.6.1 [1.5.1] USE="doc lapack -test" 0 kB > > Should I mask numpy-1.6.1 or how are the chances that sage will work > with numpy-1.6.1? >
At least until this Bug https://bugs.gentoo.org/show_bug.cgi?id=371099 is resolved (sog) sage requires ~numpy-1.5.1 I'm not sure exactly the impact on your system of masking >=numpy-1.6.0 but you could try that and see what emerge -puDNv world gives. I don't see which component, if any, of couchdb is pulling in numpy or where else numpy is needed on your system. Oh, and you will also have to mask >=pexpect-2.4 Steve

Attachments

File name MIME type
signature.asc application/pgp-signature

Replies

Subject Author
Re: [gentoo-science] sci-mathematics/sage-4.7.1 and numpy version fbissey@××××××××××××.nz
Re: [gentoo-science] sci-mathematics/sage-4.7.1 and numpy version rose@××××××××××××××.de