Gentoo Archives: gentoo-science

From: fbissey@××××××××××××.nz
To: gentoo-science@l.g.o
Subject: [gentoo-science] clisp and pari-2.5
Date: Mon, 22 Aug 2011 22:05:20
Message-Id: 20110823100002.tqso4swwogkwo4s4@webmail.slingshot.co.nz
Hi,

A week or two ago, Andrey shared his concerned about the incompatibilities
between clisp and pari-2.5.0. I have looked a the situation a bit more deeply
and a fix won't be easy. clisp has been a few deprecated object for a while.
Also the glue between libpari and lisp has been done right on the lisp side. I
am not confident about that.

I think it would be prudent to restrict clisp to pari-2.3 for now. Hopefully
clisp upstream will move to pari-2.5. It certainly will be painful.
Apart from slotting we could possibly ship a separate libpari-2.3 sitting on its
own (i.e. without the gp interpreter or the help system, just libpari and its
headers). That would be an extreme measure if we decide to get rid of pari-2.3
and clisp cannot be fixed.

Francois