Gentoo Archives: gentoo-science

From: fbissey@××××××××××××.nz
To: gentoo-science@l.g.o
Subject: Re: [gentoo-science] new blas infrastructure and prefix
Date: Fri, 02 Sep 2011 13:32:42
Message-Id: 20110903012725.cx0kgss04coo8swg@webmail.slingshot.co.nz
In Reply to: Re: [gentoo-science] new blas infrastructure and prefix by Johan Hattne
Quoting Johan Hattne <jhattne@×××.gov>:

> On 30 Aug 2011, at 12:49, fbissey@××××××××××××.nz wrote: > >> Hi all, >> >> So I was looking at the science overlay from my prefix on OS X. >> And portage wanted me to upgrade my blas/cblas/lapack stack to the >> new structure. I know they are marked ~x86 and ~amd64 but it doesn't >> look good considering that I had a working stack in my prefix before. >> >> So I may make things a little more prefix friendly (OS X in particular) >> in the coming days. I am also thinking of adding an ebuild to use the >> native vectorize framework on OS X, unless someone strongly objects to it. > > Hi Francois; > > With the CBLAS reference implementations, you may run into a problem > with the test suite on Darwin. I tried to sort this out earlier this > year (see > http://icl.cs.utk.edu/lapack-forum/archives/lapack/msg00997.html), > but I'm not even sure upstream recognises the problem. Please let me > know if at least you can reproduce the issue, and then maybe we can > try again to get it fixed. >
Looking at that thread they don't seem to see a problem. I haven't tackled cblas-reference yet but I have made an ebuild to use the vectorize framework from apple on OS X (I'll put it in the overlay soonish) and the test suite for lapack-reference totaly failed when built with either blas-reference or vectorize. I am guessing that it must be similar to what you got with cblas-reference. Francois

Replies

Subject Author
Re: [gentoo-science] new blas infrastructure and prefix Andrea Arteaga <andyspiros@×××××.com>