Gentoo Archives: gentoo-science

From: fbissey@××××××××××××.nz
To: gentoo-science@l.g.o
Subject: Re: [gentoo-science] numpy conflict with sage-on-gentoo
Date: Wed, 30 May 2012 21:02:43
Message-Id: 20120531063236.uw5rr40kksckkckc@webmail.slingshot.co.nz
In Reply to: Re: [gentoo-science] numpy conflict with sage-on-gentoo by Thomas Kahle
Quoting Thomas Kahle <tomka@g.o>:

> On 17:27 Wed 30 May 2012, P Purkayastha wrote: >> On 05/30/2012 05:07 PM, Thomas Kahle wrote: >> > Hi, >> > I'm trying to build sage on gentoo but I get a conflict: >> > >> > !!! Multiple package instances within a single package slot have >> been pulled >> > !!! into the dependency graph, resulting in a slot conflict: >> > >> > dev-python/numpy:0 >> > >> > (dev-python/numpy-1.5.1::sage-on-gentoo, ebuild scheduled for >> merge) pulled in by >> > ~dev-python/numpy-1.5.1 required by >> (sci-mathematics/sage-5.0-r1::sage-on-gentoo, ebuild scheduled for >> merge) >> > >> > (dev-python/numpy-1.6.0::gentoo, ebuild scheduled for merge) >> pulled in by >> > >=dev-python/numpy-1.5[lapack] required by >> (sci-libs/scipy-0.9.0-r1::gentoo, ebuild scheduled for merge) >> > >> > Any suggestions? >> > >> > Thanks! >> > Thomas >> > >> >> The latter package scipy depends on >=numpy-1.5 whereas sage depends >> on =numpy-1.5.1. So, simply mask the higher versions of numpy: >> >> If you have /etc/portage/package.mask directory then, >> >> echo ">dev-python/numpy-1.5.1" >> /etc/portage/package.mask/mask_numpy >> >> otherwise >> >> echo ">dev-python/numpy-1.5.1" >> /etc/portage/package.mask > > ... and now it pulls in eselect-cblas and gsl which are blocking each other: > > [blocks B ] app-admin/eselect-cblas ("app-admin/eselect-cblas" > is blocking sci-libs/gsl-1.15-r2) > > * Error: The above package list contains packages which cannot be > * installed at the same time on the same system. > > (app-admin/eselect-cblas-0.1::gentoo, ebuild scheduled for merge) > pulled in by > app-admin/eselect-cblas required by > (sci-libs/cblas-reference-20030223-r4::gentoo, ebuild scheduled for > merge) > > (sci-libs/gsl-1.15-r2::science, installed) pulled in by > sci-libs/gsl required by (media-gfx/inkscape-0.48.2::gentoo, installed) > >=sci-libs/gsl-1.15 required by > (sci-mathematics/sage-5.0-r1::sage-on-gentoo, ebuild scheduled for > merge) >
I think that's a different problem. You are using blas stuff from the science overlay but the version of cblas-reference from the main tree as a higher version number than the one from the science overlay (3. something?). So you probably have to mask sci-libs/cblas-reference::gentoo. For your original problem, yes portage should solve the conflict, this is very strange, are numpy or scipy part of your world file? Francois

Replies

Subject Author
[gentoo-science] Building sage-on-gentoo Thomas Kahle <tomka@g.o>
Re: [gentoo-science] numpy conflict with sage-on-gentoo Thomas Kahle <tomka@g.o>