Gentoo Archives: gentoo-science

From: Steven Trogdon <strogdon@×××××.edu>
To: gentoo-science@l.g.o
Subject: Re: [gentoo-science] sci-libs/scipy-0.9.0-r1 undefined symbol: clapack_sgesv
Date: Sat, 11 Jun 2011 05:01:02
Message-Id: 20110610235859.64e4bb3e@pavilion64.home.lan
In Reply to: Re: [gentoo-science] sci-libs/scipy-0.9.0-r1 undefined symbol: clapack_sgesv by Francois Bissey
On Wed, 8 Jun 2011 08:07:10 +1200
Francois Bissey <fbissey@××××××××××××.nz> wrote:

> > EL Tue, 7 Jun 2011 07:33:27 +1200 > > > > Francois Bissey <fbissey@××××××××××××.nz> escrigué: > > > I note you are using numpy-1.6.0 I don't if that's linked to that but > > > sage will not work properly with it: > > > http://trac.sagemath.org/sage_trac/ticket/11334 > > > Can you try again with numpy-1.5.1 at least. > > > > I am a bit surprised, but downgrading numpy actually worked. Thanks a > > lot for your help, Francois! Sage-4.7 should depend on ~numpy-1.5.1 > > then, since it already depends on >=numpy-1.5.1. > > > > > And then what are the outputs of: > > > ldd /usr/lib64/python2.7/site-packages/numpy/core/_dotblas.so > > > ldd /usr/lib64/python2.7/site-packages/numpy/linalg/lapack_lite.so > > > > They link to lapack, blas and cblas, and they didn't change when I > > downgraded numpy. > > I fixed the numpy dependencies in the sage tree. It is still curious that > scipy didn't apparently build properly when using numpy-1.6.0. Someone should > investigate that. > > Francois >
It appears that this issue may arise somewhere in the distutils that's shipped with numpy-1.6.0. We'll see. See bug http://bugs.gentoo.org/show_bug.cgi?id=371099 Steve

Attachments

File name MIME type
signature.asc application/pgp-signature