Gentoo Archives: gentoo-science

From: My Th <rei4dan@×××××.com>
To: gentoo-science@l.g.o
Subject: Re: [gentoo-science] blas/lapack stuff
Date: Tue, 11 Oct 2011 09:26:09
Message-Id: 1318325142.26355.199.camel@RD-OC
In Reply to: [gentoo-science] blas/lapack stuff by "Andrey G. Grozin"
O , 2011-10-11 11:42 +0700, Andrey G. Grozin rakstīja:
> Hello *, > > I use the science overlay, and for quite some time I have problems with > blas/lapack. Each attempt to emerge -uD @world produces something like > > ================================================================================ > [blocks B ] app-admin/eselect-blas ("app-admin/eselect-blas" is > blocking sci-libs/lapack-reference-3.3.1-r1, sci-libs/gsl-1.15-r1, > sci-libs/blas-reference-20110418) > [blocks B ] app-admin/eselect-cblas ("app-admin/eselect-cblas" is > blocking sci-libs/lapack-reference-3.3.1-r1, sci-libs/gsl-1.15-r1, > sci-libs/blas-reference-20110418) > [blocks B ] app-admin/eselect-lapack ("app-admin/eselect-lapack" is > blocking sci-libs/lapack-reference-3.3.1-r1, sci-libs/gsl-1.15-r1, > sci-libs/blas-reference-20110418) > > Total: 21 packages (21 upgrades), Size of downloads: 19,795 kB > Conflict: 4 blocks (3 unsatisfied) > Portage tree and overlays: > [0] /usr/portage > [1] /var/lib/layman/science > > * Error: The above package list contains packages which cannot be > * installed at the same time on the same system. > > (sci-libs/lapack-reference-3.3.1-r1::science, ebuild scheduled for > merge) pulled in by > >=sci-libs/lapack-reference-3.3 required by > (virtual/lapack-3.3::science, ebuild scheduled for merge) > > (app-admin/eselect-cblas-0.1::gentoo, installed) pulled in by > app-admin/eselect-cblas required by > (sci-libs/blas-atlas-3.9.23-r4::gentoo, installed) > > (sci-libs/blas-reference-20110418::science, ebuild scheduled for merge) > pulled in by > >=sci-libs/blas-reference-20110417 required by > (virtual/blas-2.1::science, ebuild scheduled for merge) > > (app-admin/eselect-blas-0.1::gentoo, installed) pulled in by > app-admin/eselect-blas required by > (sci-libs/blas-atlas-3.9.23-r4::gentoo, installed) > > (sci-libs/gsl-1.15-r1::science, ebuild scheduled for merge) pulled in by > sci-libs/gsl required by (sci-mathematics/giac-0.9.3::grozin, > installed) > sci-libs/gsl required by (sci-libs/mathgl-1.11.2::gentoo, installed) > sci-libs/gsl required by (sci-libs/tamu_anova-0.2.1::gentoo, > installed) > sci-libs/gsl required by (sci-visualization/qtiplot-0.9.8.8::gentoo, > installed) > sci-libs/gsl required by (media-gfx/asymptote-2.13::grozin, installed) > sci-libs/gsl required by (media-gfx/inkscape-0.48.2::gentoo, > installed) > sci-libs/gsl required by (app-office/kspread-2.3.3::gentoo, installed) > >=sci-libs/gsl-1.10 required by > (sci-visualization/pyxplot-0.8.4::gentoo, installed) > >=sci-libs/gsl-1.14-r2 required by (virtual/cblas-2.0::science, ebuild > scheduled for merge) > > (app-admin/eselect-lapack-0.1::gentoo, installed) pulled in by > app-admin/eselect-lapack required by > (sci-libs/lapack-atlas-3.9.23-r3::gentoo, installed) > ================================================================================ > Any ideas? > > Andrey >
Hi! You have to resolve the blockers: - Unmerge blas-atlas, lapack-atlas, eselect-{blas,cblas,lapack} - Upgrade world - Emerge sci-libs/atlas - Eselect your blas, cblas, lapack implementations - To be sure that all links properly, run revdep-rebuild If eselect fails complaining that some file is not a symlink, run: emerge -1 atlas gsl lapack-reference blas-reference Alter that eselecting should work without errors. If you do not want atlas versions of blas, cblas and lapack, you can skip the step where atlas is installed. Reinis