Gentoo Archives: gentoo-science

From: Christopher Schwan <cschwan@××××××××××××××××××.de>
To: gentoo-science@l.g.o
Subject: Re: [gentoo-science] 'emerge -vuND sage' fails due to issues with masking.
Date: Mon, 22 Aug 2011 09:45:22
Message-Id: 23893388.0cAe6xTicH@cschwan-laptop
In Reply to: [gentoo-science] 'emerge -vuND sage' fails due to issues with masking. by rose@rz.uni-potsdam.de
On Monday 22 August 2011 11:29:34 rose@××××××××××××××.de wrote:
> 'emerge -vuND sage' now fails for me with: > > root@caiman:/root(61)# emerge -vuND sage > > These are the packages that would be merged, in order: > > Calculating dependencies... done! > [ebuild U #] sci-mathematics/sage-baselayout-4.7.2_alpha1 [4.7.1] > USE="X -debug -testsuite" 1,111 kB [1] > [ebuild U ] sci-mathematics/sage-extcode-4.7.2_alpha1 [4.7.1] > 11,894 kB [1] > [ebuild N ] sci-mathematics/pari-data-20110727 45,753 kB [0] > [ebuild UD ] dev-python/pexpect-2.0 [2.4-r1] USE="(-doc%*) > (-examples%*)" 0 kB [1] > [ebuild UD ] dev-python/numpy-1.5.1 [1.6.1] USE="doc lapack -test" > 0 kB [0] > [ebuild U ] sci-mathematics/sage-notebook-0.8.20 [0.8.19] > USE="java" 18,442 kB [1] > [ebuild N ] sci-mathematics/pari-2.5.0-r3 USE="X data doc fltk > gmp" 2,651 kB [0] > [ebuild N ] dev-python/mpmath-0.17 USE="doc examples gmp > -matplotlib -test" 0 kB [0] > [ebuild N ] sci-libs/flint-1.6 USE="doc ntl -test" 0 kB [1] > [ebuild N #] sci-mathematics/sage-doc-4.7.2_alpha1 USE="pdf > -html" 53,162 kB [1] > [ebuild N ] sci-mathematics/eclib-20100711 USE="-pari24" 0 kB [1] > [ebuild N #] sci-mathematics/lcalc-1.23-r4 USE="pari" 0 kB [1] > [ebuild N ] dev-python/sympy-0.7.1 USE="doc examples gtk latex > opengl pdf png texmacs -imaging -ipython -mathml -test" 0 kB [0] > [ebuild N ] sci-mathematics/sympow-1.018.1_p8-r1 USE="-pari24" 0 kB > [1] [ebuild N ] sci-mathematics/genus2reduction-0.3_p8-r1 0 kB [1] > [ebuild N ] dev-python/networkx-1.2 USE="examples" 0 kB [1] > [ebuild N ] dev-tex/sage-latex-2.2.5-r2 USE="examples" 0 kB [1] > [ebuild N ] sci-mathematics/polybori-0.7.1 USE="doc gd sage" 0 kB [1] > [ebuild N #] sci-mathematics/sage-clib-4.7.2_alpha1 0 kB [1] > [ebuild N #] sci-mathematics/sage-4.7.2_alpha1 USE="examples > latex -mpc -testsuite" 0 kB [1] > > Total: 20 packages (3 upgrades, 2 downgrades, 15 new), Size of > downloads: 133,011 kB > Portage tree and overlays: > [0] /usr/portage > [1] /var/lib/layman/sage-on-gentoo > > The following mask changes are necessary to proceed: > #required by sci-mathematics/sage-4.7.2_alpha1, required by sage (argument) > # /etc/portage/package.mask: > #required by sci-mathematics/sage-4.7.2_alpha1, required by sage (argument) > # /var/lib/layman/sage-on-gentoo/profiles/package.mask: > # preparing 4.7.2 > > > =sci-mathematics/lcalc-1.23-r4 > > #required by sci-mathematics/sage-4.7.2_alpha1, required by sage (argument) > # /var/lib/layman/sage-on-gentoo/profiles/package.mask: > # preparing 4.7.2 > > > =sci-mathematics/sage-clib-4.7.2_alpha1 > > #required by sci-mathematics/sage-4.7.2_alpha1, required by sage (argument) > # /var/lib/layman/sage-on-gentoo/profiles/package.mask: > # preparing 4.7.2 > > > =sci-mathematics/sage-baselayout-4.7.2_alpha1 > > #required by sage (argument) > # /etc/portage/package.mask: > #required by sci-mathematics/sage-4.7.2_alpha1, required by sage (argument) > # /var/lib/layman/sage-on-gentoo/profiles/package.mask: > # preparing 4.7.2 > #required by sci-mathematics/sage-4.7.2_alpha1, required by sage (argument) > # /var/lib/layman/sage-on-gentoo/profiles/package.mask: > # preparing 4.7.2 > #required by sci-mathematics/sage-4.7.2_alpha1, required by sage (argument) > # /var/lib/layman/sage-on-gentoo/profiles/package.mask: > # preparing 4.7.2 > #required by sage (argument) > # /var/lib/layman/sage-on-gentoo/profiles/package.mask: > # preparing 4.7.2 > > > =sci-mathematics/sage-4.7.2_alpha1 > > #required by sci-mathematics/sage-4.7.2_alpha1, required by sage (argument) > # /etc/portage/package.mask: > #required by sci-mathematics/sage-4.7.2_alpha1, required by sage (argument) > # /var/lib/layman/sage-on-gentoo/profiles/package.mask: > # preparing 4.7.2 > #required by sci-mathematics/sage-4.7.2_alpha1, required by sage (argument) > # /var/lib/layman/sage-on-gentoo/profiles/package.mask: > # preparing 4.7.2 > #required by sci-mathematics/sage-4.7.2_alpha1, required by sage (argument) > # /var/lib/layman/sage-on-gentoo/profiles/package.mask: > # preparing 4.7.2 > #required by sage (argument) > # /var/lib/layman/sage-on-gentoo/profiles/package.mask: > # preparing 4.7.2 > #required by sci-mathematics/sage-4.7.2_alpha1, required by sage (argument) > # /var/lib/layman/sage-on-gentoo/profiles/package.mask: > # preparing 4.7.2 > > > =sci-mathematics/sage-doc-4.7.2_alpha1 > > But I think that I have just set this requested masking > /etc/portage/package.maks: > > > root@caiman:/root(62)# cat /etc/portage/package.mask > > > =dev-java/jgraphx-1.4.1.1 > > =sci-libs/sprng-4.0 > > #required by sci-mathematics/sage-4.7.2_alpha1, required by sage (argument) > # /var/lib/layman/sage-on-gentoo/profiles/package.mask: > # preparing 4.7.2 > > > =sci-mathematics/lcalc-1.23-r4 > > #required by sci-mathematics/sage-4.7.2_alpha1, required by sage (argument) > # /var/lib/layman/sage-on-gentoo/profiles/package.mask: > # preparing 4.7.2 > > > =sci-mathematics/sage-clib-4.7.2_alpha1 > > #required by sci-mathematics/sage-4.7.2_alpha1, required by sage (argument) > # /var/lib/layman/sage-on-gentoo/profiles/package.mask: > # preparing 4.7.2 > > > =sci-mathematics/sage-baselayout-4.7.2_alpha1 > > #required by sage (argument) > # /var/lib/layman/sage-on-gentoo/profiles/package.mask: > # preparing 4.7.2 > > > =sci-mathematics/sage-4.7.2_alpha1 > > #required by sci-mathematics/sage-4.7.2_alpha1, required by sage (argument) > # /var/lib/layman/sage-on-gentoo/profiles/package.mask: > # preparing 4.7.2 > > > =sci-mathematics/sage-doc-4.7.2_alpha1 > > Any hint is apprecieated.
Hi, I dont know why portage wants to install 4.7.2_alpha1 but it should not - the latest stable is 4.7.1. Refresh your overlay (I just made a small change) and try again. Also, do not forget to compile sage-baselayout and sage itself with USE=testsuite because 4.7.1 is broken without (see other thread on the list). If it does not work, send me a list of already installed sage packages and their corresponding versions. If you are using eix, type eix -I sage- to get that list. Cheers, Christopher

Replies

Subject Author
Re: [gentoo-science] 'emerge -vuND sage' fails due to issues with masking. rose@××××××××××××××.de